Breaking out of SSL after ProSite signup

I am using Stripe as a payment gateway and have SSL setup to be used on my prosite signup/checkout.

The issue I'm having is that after signing up, the ProSites confirmation message directs users to their user admin but uses an https:// link (e.g., https://testsite.mysite.ca/wp-admin/). Clicking on this link gives the user a security warning and doesn't let them into their admin panel. Is there a way to have ProSites link to http:// rather than https://? Any other workaround?

  • Tom Eagles

    HI Erica,

    Many thanks for contacting us, this is usually caused by using a single site SSL rather than a wildcard SSL certificate, so whilst your maindomain.com is covered by it your subsites such as mysite.ericasawesomehosting.com wont be. Hence the security warning as the SSL certificate isnt valid for the subdomains.

    You have a couple of options open to you here,

    a)Upgrade your SSL certificate to a wildcard one which means not only your main site will be protected by the SSL but all your subsites will be as well.

    b)You could use our domain mapping plugin and use the force http on wp-admin option see the usage tab here

    Domain Mapping - Front-end SSL
    Force https in front-end and/or admin area.
    You can force https in login and admin pages, only applicable if you have an SSL certificate.

    And you can also force http/https in front-end pages as well, applicable if you have SSL enabled.

    If you have any further questions feel free to get back to me, hope you had an awesome weekend!

    Cheers Tom

  • Erica

    Hi Tom -

    I only want my SSL on my checkout page where customers are entering credit card data. I have no need for a SSL on all my pages and don't want it there.

    All I need to change is the links that appear on the ProSite confirmation page. They tell the user their site has been created and then direct the user to click on a link to access their admin panel. These links are incorrectly in the format of https:// and I want these links to appear in the format of http://

    While I appreciate your other suggestions, they make things rather complex, and all I need is a simple fix of the "s" removed from the URL Is there any way to do this?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.