Browser Caching is not enabled - Siteground site

Hi guys,

Hope that you're well? After speaking to Rupok on the live support I was wondering if anyone could help with sorting out browser caching? Siteground are saying that they have thier 'supercacher' enabled but I beleive I need to do something else?

  • Predrag Dubajic

    Hey Jay,

    Hope you're doing well today :slight_smile:

    As far as I know SuperCacher is managing server side caching, I might be wrong but it would be best getting in touch with your hosting provider and ask them if SuperCacher is able to handle browser side caching as well.
    If it can ask them why google page speed test is showing that browser caching is not enabled.

    If it can't then check the HB instructions as Rupok already mentioned in chat and ask them to add the required code to nginx.conf file, this is the code needed:

    location ~* \.(txt|xml|js)$ {
        expires 8d;
    }
    
    location ~* \.(css)$ {
        expires 8d;
    }
    
    location ~* \.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac)$ {
        expires 8d;
    }
    
    location ~* \.(jpg|jpeg|png|gif|swf|webp)$ {
        expires 8d;
    }

    Let us know how it goes :slight_smile:

    Best regards,
    Predrag

  • Adam Czajczyk

    Hello Jay!

    In many cases on a shared server you cannot set your own configuration of web server software (nginx in this case). Therefore you need to ask host staff if they could do this for you. I understand that they made some changes for you and they enabled "dynamic caching".

    I'm not however sure whether this is the same that Predrag suggested. Did they confirm that they enabled browser caching for you as well? If you go to the "Hummingbird -> Browser Caching" page do you know see current status of caching as enabled?

    Could you please share a link to your site so I could test it from outside?

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.