Browser Caching is not working properly

I am getting the following message.
Browser Caching is not working properly:
- Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)
- Another plugin may be interfering with the configuration
If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

    Nithin

    Hi Brandon,

    Hope you are doing good today.

    This is really odd, just to be sure, other website on the same server works fine with Hummingbird plugin, right?

    Checking the Browser caching page in Hummingbird, it seems like the values are being overridden, it could be either from any of the plugins, or from your server.

    Just to be sure that we don't miss out anything, please get in touch with your host to see whether it sets any default values for JavaScript, media, images. At the moment, the values for these are set to 4 hours, and hence overriding Hummingbird settings for 8 days.

    If there isn't any such setting that's overriding via your host, then to test this extensively, please send us your credentials, so that we could give a closer look. You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Please do let us know what you host has to say about this, have a nice day.

    Kind Regards,
    Nithin

    Nithin

    Hello Brandon,

    Sorry for the delay in getting back to you, the issue was conflict with one of the .htaccess rules, most probably from the WP Security plugins codes. I have changed the order in which the Hummingbirds Browser cache codes are called in .htaccess code, by adding it before the WP security plugins code.

    Once done, browser cache is working fine in your server now.

    Please let us know if you still need any further assistance. Have a nice day ahead.

    Best Regards,
    Nithin