Browser Caching is not working properly:

Even though the extension is installed in php, I still get this error:

- Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)
- Another plugin may be interfering with the configuration
If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

  • Rupok
    • Support Ninja

    Hi Fernando,

    I'm so sorry to hear the inconvenience. Can you please confirm the "expires" module is "enabled" in your server? If yes, then can you please do a plugin conflict test just to make sure no other plugin is causing this? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Please let us know the result. If nothing above helps, we will be glad to investigate further.

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Fernando
    • Design Lord, Child of Thor

    I explained in the topic that the extensions are active on the server. I already frized the plugin compability test and that's not the problem. Will you give me automatic CTRL + C / CTRL + V response or will they help me? I pay annual subscription with you for support, I never ask for support and when I ask you, they will not help me!

  • Kasia Swiderska
    • Support nomad

    Hello Fernando,

    I'm extremely sorry for that! There is misunderstanding, that came from our side.

    On some hosting module expires is installed, but then it needs to be enabled for accounts. This is what we were asking.

    If that is not the case, can you try enabling cache manually as described under the "Want to do it manually?" link on the Browser Cache page?

    Let me know how it goes.

    kind regards,
    Kasia

  • Kasia Swiderska
    • Support nomad

    Hello Fernando,

    Huh, that is not correct. it should show there as on the gZip page. But I see that there is a 500 internal server error in browser console so it might be reason why it is not showing.
    Can you enable debug mode in your WordPress and check again that page, so error will show in the debug.log? To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
    define('WP_DEBUG', true);
    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    I would need then to see content of the debug.log file - so please upload it to service like a Dropbox and paste link here.

    kind regards
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.