Browser Caching is not working properly

Hi,
I get the following error message:

Browser Caching is not working properly:

- Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)
- Another plugin may be interfering with the configuration
If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

So here I am

Best Regards

  • Katya Tsihotska

    Hi Arom77

    Hope you're having a wonderful day!

    The message means that Hummingbird was not able to detect whether the browser cache has been properly enabled or not. Usually, it means that it's not working and most often it is caused by the fact that "mod_expires" (in case of Apache server) or "ngx_http_headers" (in case of nginx server) module is either not enabled in server config or not configured properly.

    There may be other reasons for this too but the first thing to check would be to confirm whether "mod_expires" or "ngx_http_headers_module" module is active and configured to let you make changes to it via .htaccess. That being said, please get in touch with your host and ask them if it is enabled.

    If it's not, ask them whether they could enable it for you. If they confirm that it's working, but you still can't enable browser caching, just to make sure no other plugin is causing this issue, can you please do a plugin conflict test? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Let us know about results. Also, if you are still having troubles with this, could you please grant us temporary support access to your website so we can have a better look at your setup and settings? You can grant us access via WPMUDEV Dashboard plugin, there's no need to share credentials. Here's our detailed documentation page about it:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Kind regards,
    Katya