Browser Caching is not working properly

Browser Caching is not working properly:

- Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)
- Another plugin may be interfering with the configuration

If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

Can you please help me solve this?

  • Kris
    • Support

    Hi rene

    Hope you are doing good today.

    Would you please run a conflict test? Please deactivate all plugins except Hummingbird and check if the problem gone. If so, then enable all plugins one by one and find which one is having conflict.

    Try also to check your ".htaccess" file and make sure that Hummingbird caching rules are properly added there.
    To do that go to Hummingbird -> Browser Caching, on the right in "Enable Caching" tab you will see .htaccess rules. Compare this with your .htaccess on your FTP.

    Some of host providers have browser caching defined on server directly, and they block these changes to be made via .htaccess rules. If they do that, ask them if there is a posibility to change the server settings to enable caching or to allow these changes to be made from .htaccess.

    If your host says that this is properly configured would you mind support access so we can check what else could be the cause. To do that you can read this https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Also please send through our secure contact form here below informations https://premium.wpmudev.org/contact/#i-have-a-different-question and make sure that subject is "I have a different question" and:
    - Mark to my attention: ATTN: Krzysztof Tomczyk
    - FTP credentials (host / username / password)
    - Link back to this thread

    Please confirm here in thread that you have sent that message.

    Kind Regards,
    Kris

  • Kris
    • Support

    Hi rene

    Using two plugin on site which make the same things, in this case caching, it can cause errors in correct functioning of those plugins. In your case additional cache option from server cause this issue.

    I recommend to use only one option:
    1. cache from Hummingbird (which you can also connect with cloudflare)
    2. or disable cache in Hummingbird and use this from your NginX server.

    Kind Regards,
    Kris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.