Browser Caching is not working properly: - Your server may

Browser Caching is not working properly:
- Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)
- Another plugin may be interfering with the configuration
If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

I dont intall any plugin but there are this error. Are you suggest delete all network and re install or what can i do now?

  • Michael Bissett
    • Recruit

    Hey Variotik, Michael here!

    First, let's try disabling the other plugins on the Multisite temporarily, here's a way of handling that:

    If you’re logged into your site via FTP, renaming the /plugins/ folder in your WordPress install will do a soft deactivation on all plugins, this removes the code for testing and providing you don’t open the admin plugin page they won’t become deactivated in the database.

    You can then create a new /plugins/ folder and either move the plugins across one at a time or in batches whilst continuously testing.

    (I'm quoting the Getting Support page on this one, we've got a flowchart there as well that'll be handy for this testing)

    If disabling the other plugins doesn't reveal a culprit, then it's most likely the first possibility mentioned by Hummingbird (which is something only your host can take care of). It that module isn't something they offer as part of the hosting, then you'll want to manually edit your site's .htaccess, and remove the lines of code starting from this:

    # BEGIN WP-HUMMINGBIRD-CACHING

    And ending with this:

    # END WP-HUMMINGBIRD-CACHING

    Kind Regards,
    Michael

  • Frank
    • Site Builder, Child of Zeus

    Hi,

    Same problem here: deactivated all plugins, only Hummingbird running. Same message:

    "Browser Caching is not working properly:
    - Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)
    - Another plugin may be interfering with the configuration
    If re-checking and restarting does not resolve, please check with your host or open a support ticket with us."

    Theme: Twenty Sixteen

    I tried to generate an error in the htaccess, inside the <IfModule mod_expires.c>
    Changed this :
    # BEGIN WP-HUMMINGBIRD-CACHING

    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresDefault A0
    ........

    To that:
    # BEGIN WP-HUMMINGBIRD-CACHING

    <IfModule mod_expires.c>
    ExpiresActive On2 <--- changed On with On2
    ExpiresDefault A0
    ..............

    And I got a Internal Server Error, so I think my server has the "expires" module enabled.

    Hope it helps, @michael55

    Kind regards,
    Frank

  • Michael Bissett
    • Recruit

    Hey @variotik,

    I'd like to have a deeper look at your install here, could you please send in the following via our secure contact form:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    https://premium.wpmudev.org/contact/

    Frank, we'll want to take your question to a separate thread, could you open one please:

    https://premium.wpmudev.org/forums/#question

    So that we can handle your issue efficiently, as explained over here:

    https://premium.wpmudev.org/forums/topic/upgrading-to-the-latest-dashboard-gives-project-auto-upgrade-errors#post-1030729

    Kind Regards,
    Michael

  • Michael Bissett
    • Recruit

    Hey @variotik,

    On the "Browser Caching is not working properly" error, I didn't see that initially when I was inside of your site, but I did find that when it did (and it only occured after I had enable the browser caching), that when the "Re-check expiry" button was clicked, then the error went away, and things settled down.

    Are you seeing that it's gone on your end now as well?

    And Hummingbird plugin CONF?GURE SCR?PT DEFERR?NG button go to You do not have sufficient permissions to access this page error

    Yep, our developers are aware of this one, I'll let them know if this instance as well.

    You'll need to head into the Dashboard for a site on your network, like the main site, or a subsite, the Network Dashboard isn't the place to configure script deferring.

    gzip also seems to be working correctly, but the test is -20

    You mean the score for the "Enable compression" entry in the performance report was -20?

    I saw a score of 26 when I was first in there, but I also found that the .htaccess rules for the GZip compression were removed (I'm assuming from the manual deletion of the rules). I've re-inserted them for you, and I'm seeing that the site's not giving me any errors presently.

    Are you seeing that it's working properly on your end as well?

    Kind Regards,
    Michael

  • Variotik
    • The Crimson Coder

    I understand now:

    CONF?GURE SCR?PT DEFERR?NG error will fix from wpmudev team

    And you fix gzip error

    If i understand correclty; Oh my god! I think you will say error solution and i will do, but you do for me. Realy thank you very much.

    May the force be with you...

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.