Browser Caching Issue

So having an odd issue with hummingbird that I haven’t had before. Nothing I’m doing is working when it comes to changing the expiration date. It’s writing to the htaccess, it just doesn’t update my expiration date. I’ve even updated the plugin to the latest version.

http://imgur.com/a/WgyIc

What am I doing wrong?

  • Rupok
    • Support Ninja

    Hi Jeramiah,

    So sorry for the inconvenience you are having. I tried to regenerate this issue on my test site but I could not. So I think, this is your site specific issue.

    Just to make sure no other plugin is causing this, can you please do a plugin conflict test? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If this doesn't help, can you please try the manual way? As you said, writing in the .htaccess file is not working, can you please try the other instructions available when you click on the "Want to do it manually?" link? Please check the attached screenshot for reference.

    For your convenience, I'm pasting the instructions here:

    If .htaccess does not work, and you have access to vhosts.conf or httpd.conf try this:

    Look for your site in the file and find the line that starts with <Directory> – add the code above into that section and save the file.

    Reload Apache.

    If you don't know where those files are, or you aren't able to reload Apache, you would need to consult with your hosting provider or a system administrator who has access to change the configuration of your server

    Still having trouble? Open a support ticket.

    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresDefault A0

    <FilesMatch ".(txt|xml|js)$">
    ExpiresDefault A2592000
    </FilesMatch>

    <FilesMatch ".(css)$">
    ExpiresDefault A2592000
    </FilesMatch>

    <FilesMatch ".(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac)$">
    ExpiresDefault A2592000
    </FilesMatch>

    <FilesMatch ".(jpg|jpeg|png|gif|swf|webp)$">
    ExpiresDefault A2592000
    </FilesMatch>
    </IfModule>

    <IfModule mod_headers.c>
    <FilesMatch ".(txt|xml|js)$">
    Header set Cache-Control "max-age=2592000"
    </FilesMatch>

    <FilesMatch ".(css)$">
    Header set Cache-Control "max-age=2592000"
    </FilesMatch>

    <FilesMatch ".(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac)$">
    Header set Cache-Control "max-age=2592000"
    </FilesMatch>

    <FilesMatch ".(jpg|jpeg|png|gif|swf|webp)$">
    Header set Cache-Control "max-age=2592000"
    </FilesMatch>
    </IfModule>

    Please let us know if this doesn't work also. We will be glad to investigate further. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!

    Rupok

  • Jeramiah
    • Design Lord, Child of Thor

    Thank you so much for replying back so fast. I have taken the code you provided above and placed it in my .htaccess and then l have uploaded that file. I confirmed the changes took when I redownloaded the file. Yet, when I go to Google Page Insights, “Leverage Browser Caching” is still showing 5 minutes, seen here: http://imgur.com/a/twFrK

    Is it possible that:

    1) the code provided by humming bird is not in a correct format?

    2) there are files not able to be controlled by that code that still show a low expiration time?

    Would you suggest that we delete the plugin and reinstall it – or do you think that would not solve the issue?

    Thank you again for your help!

  • Kasia Swiderska
    • Support nomad

    Hello Jeramiah,

    1) the code provided by humming bird is not in a correct format?

    No, not really. If what is inside the htaccess is not working that means there is probably something that is overriding those values on different level.

    Are you using CloudFlare by any chance? CloudFlare has own values for that and Hummingbird would not override those without integrating with CF.

    There is no harm in trying to install plugin again – there is chance it might help. You can try and let us know how it went

    kind regards,

    Kasia

  • Jeramiah
    • Design Lord, Child of Thor

    well, we don’t use cloudflare but you got me thinking in a different direction — we do have server caching turned on with siteground. Once I disabled that, BAM it worked. Thank you for your thoughts, very helpful!!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.