Browser caching not working

I'm trying to activate browser caching but I'm getting the "red error block" message in the hummingbird console. What do I need to in order to get this working?

Thanks!
Joe

  • Adam Czajczyk

    Hello Joe,

    I hope you're fine today and thank you for your question!

    I checked your site with external tools (Pingdom tools and Chrome audit) and it seems that the site actually does leverage browser caching. There are some resources that are reported as having "to short cache lifetime" (though that's a different set depending on an audit tool).

    That would mean that caching is actually enabled on server side but it's "fixed" and you cannot specify cache lifetime via ".htaccess" (which may be similar to the case of gzip compression from your other thread).

    Also if there's a CDN in front of your site, settings of that CDN's cache may be reported (which again is similar to the gzip compression case).

    That said, if there is CloudFlare, you might want to disable it temporarily to see if that changes anything and if yes, then enable it again and make sure that it's configured with Hummingbird.

    If disabling CDN doesn't change Hummingbird status, it would be good to ask hosting provider how caching works on the server and if you can change "mod_expires" module settings directly via .htaccess.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.