Browser Caching with hummingbird

I can't seem to get browser caching to work with hummingbird. I continue to get the following error message:

Browser Caching is not working properly:
- Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)
- Another plugin may be interfering with the configuration
If re-checking and restarting does not resolve, please check with your

I have followed its instructions and searched the forums but can't seem to resolve this issue

  • Sajid

    Hello Taylor Beardshear,
    Hope you are doing good today and warm welcome to WPMU DEV :slight_smile:

    The message suggests that the "mod_deflate" module may not be enabled but that may not always be the case. Please double-check your server for following issues as well:

    - check if there's a Varnish cache running on server (or any other server-side caching solution) and make sure to purge/empty it

    - make sure that PHP is configured to support zlib library and that zlib output support is enabled; there's a php.ini setting for this that should be set to "on":

    zlib.output_compression = On
    In case it's set to "off" you will want to change it to "on" and restart Apache

    - there's also a slight chance that not all required MIME types are set to be handled by "mod_deflate" module; it should support at least "text/html", "text/javascript" and "text/css"

    You may need to contact your hosting provider for these steps but I hope it'll fix the issue.

    Take care and have a nice day!

    Best Regards,
    Sajid - WPMU DEV Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.