buddypress 1.2.5 is compatible to all buddypress plugins here?

Is all buddypress plugins on wpmudev are now compatible with new buddypress 1.2.5? I tried to install new buddypress 1.2.5, but things went awry, awfully bad, anti-splog stopped working, the plugin panel showed buddypress wasn't activated and the bp-group-calendar and bp-group-email weren't activated either.

I'm using multdb version 3.0, wordpress 3.0, trying to upgrade buddypress to 1.2.5

How I went about installing new buddypress 1.2.5?
I network deactivated bp-group-email bp-group-calendar, and buddypress.
cd /home/myuser/folder/
unzip buddypress.1.2.5.zip
Chmod 755 buddypress
cd buddypress
find . -type d -exec chmod 755 {} \;
find . -type f -exec chmod 644 {} \;
cd ..
cp -r buddypress /home/myuser/public_html/wp-content/plugins/
went back into admin panel, plugins section
network activated buddypress
network activated bp-group-calendar and bp-group-email

Then I saw a message in admin panel complained anti-splog is not yet ready (something of this sort), and so I re-add the settings, saved settings. Went back into admin panel and saw the same anti-splog message said it's not ready, went into setting and saw the setting wasn't there, I had to re-add, but it didn't matter! Anti-splog failed to work after buddypress update! Went into the admin panel, plugins section and saw that buddypress plugin wasn't appeared on the list, and bp-group-email and bp-group-calendar wasn't activated, and the upgrade message for buddypress is still requesting me to upgrade to new buddypress.

What's going on? Please advice, thank you!

  • argh2xxx

    Dear Aaron,

    I have been trying, but the problem prevailed!

    I did rm -rf buddypress in /plugins/
    I removed the buddypress completely and do mv /home/myuser/newbuddypress/buddypress/ /home/myuser/public_html/wp-content/plugins/

    And I still see the exact same problem! Basically, wordpress 3.0 with multisite enabled with multidb (3.0 version) and buddypress works fine! But when I try to upgrade to buddypress 1.2.5, suddenly the admin backend can't work, all plugins stop working, and so on...

    For your information, I have done upgrade for buddypress like gazillion times (an exaggeration but it only means I have done the buddypress upgrade procedure a lot), I followed the play-book by disabled all plugins before upgrading buddypress, but buddypress 1.2.5 refused to work!

    Any idea?

    Updated: Even when I added /*increase memory limit in wp-config.php */
    define('WP_MEMORY_LIMIT', '200M');
    My server got a load of memory (more than 8GB of memory), I'm pretty sure it ain't memory problem, because I don't even see the memory problem complained, but I thought just to be sure, add that in at the third time tried out for installing buddypress 1.2.5, but the problem prevailed, sadly!

  • argh2xxx

    I did that too on the third tried out! What I did?

    I download buddypress again! Then I scp -P myportnumberhere -i /myfiles/mysecurekey buddypress.1.2.5.zip user@myserver.tld:disappointed:home/user/store-folder/.

    I then do unzip buddypress.1.2.5.zip in /home/user/store-folder/ and got buddypress directory

    then I disabled all plugins and buddypress

    then I rm -rf buddypress in wp-content/plugins/

    then I move new buddypress by using command mv buddypress /home/user/public_html/wp-content/plugins/

    reactivated buddypress (network activation), and the problem began!

    Updated: for your information, I always completely destroyed the databases whenever I failed to update anything, such as buddypress or wordpress. Then I always restore a complete backup databases, so to speak, I have the perfect working databases as if the original databases have never been touched! Therefore, the databases are OK! So when I upgrade buddypress 1.2.5 from, things went wrong not because of the databases! (Maybe multidb 3.0 is not compatible with buddypress 1.2.5?)

  • argh2xxx

    Aaron, detail is here http://pastie.org/1028947.

    I tried the fourth time to install buddypress 1.2.5, and this time, I used define('WP_DEBUG', true); to see those warnings and notices! Obviously those are what caused my admin backend of main site for wordpress 3.0 stop working correctly, example, plugins won't show in the right link header such as network, and inactive, recent active and so on, and new buddypress disappear from network link completely when click on it, click on network link redirect to as if plugins within wordpress 3.0 without multisite enabled since network link complete disappears! Yellow highlight on the top where it says something that I have to update the site, click on it only results in cannot connect to database malform, something of that sort!

    antisplog requests to enter api keys again, when enter and hit saved, nothing saved, so you can do like that forever in a loop!

    Aaron, yes, I have errors! Those are my errors! Plus, I don't spend time posting in details and reinstall buddypress like 4 times already if I don't have issue with buddypress 1.2.5! :slight_smile: I'm not a time waster, either mine or your time, because time is very valuable indeed!

    By the way, those errors/warnings/notices are only a brief portion that I copy and paste to pastie, because there is a lot more of those and others! I just thought about copying what is obvious, especially the one relates to antisplog and multidb and buddypress.

  • argh2xxx

    OK, maybe some global buddypress table needed to be added into db-config.php for multidb? Because I install fresh wordpress 3.0 and buddypress, then upgrade buddypress to 1.2.5 and found these problems! So my fresh installed of wordpress 3.0 and buddypress isn't had any global table besides add_global_table('ust'); in db-config.php. Maybe this is the cause of unable to update buddypress to buddypress 1.2.5? So what global tables do I need to add into db-config.php?

  • argh2xxx

    Yes, I'm using the latest multidb, which is version 3. I'm working on looking and weeding out the error in error log, I got one huge error log, my websites got bombarded with traffic, so it's really difficult for me to weed out errors that are related to the upgrade moment from buddypress to buddypress 1.2.5. If you have any idea of how weeding out errors easily, please let me know! I'm looking aimlessly that anything which has to do with buddypress and multidb and wordpress 3.0. Also once again, what global table that I need to add into db-config.php for upgrading buddypress? As of now, no buddypress's global table is in db-config.php, but buddypress works just fine!

  • argh2xxx

    Yay, finally, I got the upgrade from to 1.2.5!

    Here is what I think what had happened that prevented me from upgrading buddypress!

    In db-config.php (multidb version 3), if you are using the plugin of domain mapping from wpmudev.org, you must comment out the line say add_global_table('ust'); before upgrading buddypress.

    Also, I forced upgrade by destroy the databases (multi databases), then chmod 000 all plugin files that were activated, also I did mv mu-plugins to mu-plugins-backupcopy (this way no mu-plugins plugins available to interrupt the upgrading process). Also, chmod 000 sunrise.php and so on, but the only one plugin file that I did not touch and leave it alone was db-config.php and db.php from multidb plugin!

    I also did rm -rf buddypress in wp-content/plugins/, and then replace that with buddypress 1.2.5 directory buddypress. That's mv store-directory/buddypress.1.2.5/buddypress /wp-content/plugins/.

    Then I restored the backup databases 4096 or 256 if you're using 256.

    Login to admin panel as super-admin, and everything seems fine! I then mv mu-plugins-backupcopy back to mu-plugins. I also then chmod 644 the external plugin files that resided in /wp-content/. Then in db-config.php, I remove the comment mark in front of add_global_table('ust'); to enable domain mapping again!

    It works!

    One only weird thing I saw so far is that when a new user join the network, without signup or join a group, he/she will not belong to a group is correct, but after only he or she begin to write a response or a topic in forum of a group (of any group), he/she automatically join the public group even though there he/she did not click on the join group button anywhere, and the topic got posted!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.