BuddyPress 1.2.9 compatibility

Are there plans to bring this theme up-to-date so that it can be used with the latest BuddyPress version?
If so, is there a roadmap or any estimation on when will that happen?