[BuddyPress Activity +] Disable licghtbox in activity+ plugin

Hi,
I have activity + on my buddypress site. When I uploading a image it's get very blurry in the "feed". I would like to disable lightbox so that it just uploads regular pictures directly in the stream. is that possible?

  • Dimitris
    • Support Star

    Hello there Nicklas,

    hope you're doing good today and thanks for reaching us! :slight_smile:

    In order to disable Lightbox completely, please edit wp-config.php file and insert the following line just above the /* That's all, stop editing! Happy blogging. */ comment:
    define( 'BPFB_USE_THICKBOX', false );

    Warm regards,
    Dimitris

  • Dimitris
    • Support Star

    Hey there Nicklas,

    I just gave this another try in a local website using TwentySeventeen theme and just our basic plugins (HummingBird, Defender, Smush, SmartCrawl) and I can't get any lightbox in any activity page.

    As this may be happening in your end due to another plugin or active theme, could you please create a new subsite based on the one you use now via our Cloner plugin?
    https://premium.wpmudev.org/project/cloner/
    In this new subsite, please deactivate all other plugins apart from BuddyPress and BuddyPress Activity +, enable a default theme like TwentySeventeen and check activity pages once more. If the issue is gone, start activating back the plugins and theme you used before, one by one this time, checking what's going on with the image links, until you reproduce the same issue again, thus finding the conflicted combination.
    It's also strongly advised to disable any caching while testing this, to be sure about the results. By "all" I mean caching coming from plugins, MU plugins, server side, 3rd party mechanisms like Cloudflare etc.

    Looking forward for your results! :slight_smile:

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.