BuddyPress and https

I've been setting up a buddypress site with 4 underlying blogs and was originally using the default buddypress theme with some tweaking.

I decided to try out some of the buddypress themes available (using corporate right now) The WPMU DEV themes call on https pages which do not exist in my intsallation . . . why is that?

That is - my site works fine with the buddypress default them - but with a WPMU DEV theme it does not work as when "members", for example is clicked - it goes to an https page giving a "not found error".

Why would the theme do this?

Thanks

  • Mason
    • DEV MAN’s Sidekick

    Hiya savvycs,

    First off, welcome to WPMU DEV!

    Can you give us a URL to take a look? Also anything showing up in your error logs?

    I'm glad to help out and if we get a bit more information (and can see the issue in action) I bet we can get it sorted.

    Also, you mentioned you're running WordPress multi-site - are you running multi-site in a sub-directory/domain or is it installed at the root?

    Thanks!

  • savvycs
    • Flash Drive

    Hi dapadoo

    Thanks for the thought . . . no I'm not logging in there.

    Site works fine with the default buddypress theme - but not with WPMU Dev ones.

    I've noticed that if I delete the "s" in URL . . . then it displays fine.

    Cheers
    Corey

  • savvycs
    • Flash Drive

    Hi masonjames

    I think I didn't clarify your question:

    Also, you mentioned you're running WordPress multi-site - are you running multi-site in a sub-directory/domain or is it installed at the root?

    It is installed at the root . . . and for the underlying blogs it's set to use sub-directories not sub-domains.

    Cheers
    Corey

  • Mason
    • DEV MAN’s Sidekick

    Hiya Corey,

    Thanks for the additional information. Our themes provide support for https and pull that setting for navigation if WordPress is setup to use https in the database. This support isn't in the BuddyPress default theme which is why it wouldn't happen with that enabled.

    Can you check a couple different values for me in your database?
    In the wp_options table look fro option_names 'siteurl' and 'home' - my hunch is that one or both are set to 'https://example.com' rather than 'http://example.com'

    Let us know. If that doesn't sort it for you, we'll continue to debug.

    Thanks!

  • savvycs
    • Flash Drive

    Hi

    I checked and no as far as I can see - those options are set correctly - no https. I've attached jpegs to confirm.

    I did notice as I mentioned before that if you manually remove the s from https in the url - it will then load fine (until you close the browser) Not sure whether that helps?

    Thanks,
    Corey

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    Corey,

    I'm stumped as to the 'why' this is happening and am going to ask the theme developer to take a look.

    In the meantime, a quick fix (not an actual solution - but should make things work) is to open up the theme's root folder and look for navigation.php. Comment out (put // at the front) lines 66 and 67.

    This will force the nav items to always use http rather than https.

    I'll see if Richie has any better suggestions.

    Thanks!

  • savvycs
    • Flash Drive

    OK thanks for that . . . that would be great as I'm keen to move forward.

    I'm going to try some other themes again today as I'm not sure whether it was just the one that's activated now or whether it's happening for me on each one.

    Cheers
    Corey

  • savvycs
    • Flash Drive

    Thanks Richie - looks like that's it. Theme seems to be working as expected now.

    Was it not entirely Buddypress compatible?

    Can you confirm re child themes . . .

    I upload the theme folder - in this instance 'bp-corporate' plus the folder 'bp-corporate-child' (that happens to be within the 'bp-corporate' folder when downloaded from the site) to the same themes directory . . .

    And then I activate simply the bp-corporate-child. And this is the same for all themes?

    I just wasn't sure originally when I had problems - whether it was incorrectly set up?

    Cheers
    Corey

  • Richie_KS
    • HummingBird

    yeap..using FTP
    you need to extract the bp-corporate-child from bp-corporate/themes/
    and put them inside wp-content/themes.

    alongside the bp-corporate (parent-theme) and you can activate the bp-corporate child theme only
    in network admin themes appearence and activate the bp-corporate child theme on site-admin themes selections.

    cheers

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.