Buddypress cover photo option is gone...

Hi,

All of a sudden I can not upload cover photos for my Buddypress groups.
I have one group with a cover photo and cannot change it either.

What do I need to do to be able to upload/change cover photos?

Thanks

  • Rupok
    • Support Ninja

    Hi mpress

    Hope you had a wonderful day.

    What do I need to do to be able to upload/change cover photos?

    Actually it's pretty tough to provide the exact solution without even making any tests. Can you please do a plugin conflict test just to make sure no other plugin is causing this? To know more about plugin conflict test, you can check this article: https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Have you changed your theme recently? Can you try activating any default WordPress theme and see if you can change your cover photo again?

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Have a nice day. Cheers!

  • Rupok
    • Support Ninja

    Hi mpress

    Hope you had a wonderful day.

    I just tried to regenerate the issue on my test site and I could confirm the issue. So I'm reporting this to our developer right now. Thanks for informing us.

    Please keep in mind, our developers work round the clock and they have to deal with lots of critical issues and other things. So it may take a little while for them to check this and release a fix.

    Have a nice day. Cheers!

  • Ignacio
    • HummingBird

    Hi mpress

    This issue appears only sometimes in my case. In some cases this does not only depend only on BuddyPress but also rest of plugins, theme...

    Anyway, 1.2 version comes with some improvements that will allow you to easily find what's the file that is causing the error. Update WP Hummingbird and you'll find a nice filter section in minification screen. Select Buddypress in selector and switch "minify" and "combine" switchers to off. Then try to upload the image. If it works you can now start to switch on some of them.

    Minification works in weird ways sometimes but most of the time can be fixed this way, by leaving out from minification some of the files.

    Regards.
    Ignacio.

    • mpress
      • Code Wrangler

      Hi Ignacio ,

      Thanks. I have followed your suggestions.
      After updating and activating Hummingbird I got a zero score (see screenshot).
      I run the test again then I got a beter result :slight_smile:

      But I do not see an option by the menu to open the minify section. ((see screenshot).
      Am I missing something?

      Cheers

  • Kasia Swiderska
    • Support nomad

    Hello mpress,

    From you first screen looks like the minification is disabled. Can you try enable it from the Hummingbird Dashboard and see it it will show in the options?

    If this will not help would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

    • mpress
      • Code Wrangler

      Hi Kasia,

      Minify is enabled. This is a multisite , by the network dashboards I see no minification option by the menu, but when I go to each subsite I see there only the minification option.

      So for the site for whom I have opened this thread I can see that minification is an option on each subsite...

      for my other multisite environment h4bs.com, I do not see the option for minification, neither by the network, nor for the subsites... access granted for H4bs.com

      Thanks!

      • mpress
        • Code Wrangler

        Hi Kasia,

        me again :slight_smile:

        I think it was not clear for me how to enabled minification... For a single site it is clearly that we have to active it and how... for multisite I did not understand that at the first moment.
        At least for me it was not clear that it had to be done choosing who would have rights to minify a subsite.

  • Nithin
    • Support Wizard

    Hi mpress,

    Hope you are doing good today. :slight_smile:

    and now I am able to change/add picture for a cover picture by Buddypress , but I see lots of errors:

    Glad to know that you got the change/add picture working. Sometimes the files may not play well together when minified, unchecking the minify and combine for that particular file got the cover picture working.

    This error can happen sometimes when you try to minify, clicking the RE-CHECK FILES button under Hummingbird > Minification page, will re-run your files, and should clear those errors.

    Please let us know if you still have any issues with it, happy to troubleshoot further. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi mpress,

    Hope you are doing good today. :slight_smile:

    Could you please enable support access, and please mention whether it's a subsite, or your primary site, that you are having issues with.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could give a closer look. have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi mpress,

    Thank you for enabling support access, I checked your subsite by creating a test group which is a hidden group. And uploaded a cover image, and I wasn't able to find any issue while uploading. The images are showing fine.

    Could you please advise, if I had missed out anything, so that we could give a closer look. As mentioned by Ignacio, this is not a common issue, but if you encounter such one, you'll have to disable the minify, combine, and check whether the upload works fine.

    Please clear your browser cache, and check whether you still have the same issue. I haven't deleted the test group yet, if you think the issue is sorted, please delete the test group created. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

    • mpress
      • Code Wrangler

      Hi Nithin ,

      ups... What I meant to say is that it is working, but it only works when I deactivate the combine and minify option for buddypress upload file by Hummingbird.

      When it had all itens on (include, minify and combine) upload option was hidden/not appearing.

      My intention was only to inform you (developers) that this was happening :slight_smile:

      File was minified automatically but I had to turn out combine and minify in order to be able to upload image.

      sorry for the misunderstanding.

  • Nithin
    • Support Wizard

    Hi mpress,

    Thank you for pointing this out, it's one of the anomalies that happens with minification, which doesn't always occur in every system, and as mentioned by Ignacio the fix would be to disable minify, and combine feature, as you have done, and then try to upload the image. Your current minification settings do look optimal.

    I'm passing your observation regarding this to the developer, and will check whether we could have an ideal minification settings, apart from your current configuration.

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.