buddypress error with WP3.5

Is there a simple way to eliminate this error without moving to 1.6.2 where we have other plugin compatibility issues?
PHP Warning: Missing argument 2 for wpdb::prepare()