BuddyPress forum link and Business-Feature theme

I am using the Business Feature theme. So far, so great. But, in BuddyPress, I cannot get the “New Topic” link to work in forums. Clicking it does nothing when it should show a form to create a new forum topic. If you look at the source-code for the page, however, you can see the form is there. It’s just simply not showing up on the front-end when you click “New Topic.” Is this a Business-Feature theme bug? Is there a fix perhaps?

  • Timothy
    • Chief Pigeon

    Hey there.

    I was just testing on my install and it worked fine for me.

    I presume you are referring to the forums within BuddPress and not bbPress as a stand alone?

    Just wanted to be sure I tested in the right place. :slight_smile:

    To test for conflicts can you please disable all your plugins (except BuddyPress) and then test again.

    If it then works, enable one at a time until the issue comes back. That will let us know if there is a conflict.

    Let me know.

    Cheers.

  • campuspride
    • WPMU DEV Initiate

    Thanks Timothy. Yes, I was speaking of the forums within BuddyPress. I do not have a stand-alone bbPress installation. I tried working with the plugins but it didn’t work. Then, I remembered that I had input a bit of javascript code in my header to work with something else and wondered if that could be it. It was! So, sorry for the forum post. I’ve got it working. I appreciate it.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.