BuddyPress Magazine Bugs or am I too Novice...

Brand new set-up. Got Buddypress Magazine Theme installed on multisite wordpress 3.4.1., and buddypress 1.5.6. Hate to jam so much in one thread, but they are all theme related and its possible that I am doing something wrong to cause all issues:

1- Menu. There is no control for the menu? Since set up, a random menu of pages and categories are loaded. in admin area message says "The current theme does not natively support menus, but you can use the “Custom Menu” widget to add any menus you create here to the theme’s sidebar." also, no matter what i do in the "menu settings" the menu is jacked up... is this a bug?? http://www.waarba.com/blog/

2- Summary posts on pages do not show the featured images. I am sure that I added featured image at each post... bug?? http://www.waarba.com/blog/

3- The "home" page is set to rotate thru available posts. There is only one post shown in the rotator... bug?? http://www.waarba.com/blog/

thanks in advance for your help

  • 3SixtyEvolve

    Great to see you on the Community @WAARBA!

    Ok, let me tackle your questions :slight_smile:

    1- Menu. There is no control for the menu? Since set up, a random menu of pages and categories are loaded. in admin area message says "The current theme does not natively support menus, but you can use the “Custom Menu” widget to add any menus you create here to the theme’s sidebar." also, no matter what i do in the "menu settings" the menu is jacked up... is this a bug??

    The menu as it appears in the Demo displays the design of the Magazine theme. Any page that you create will basically be added to the menu and any blog post category will be added to the Magazine tab, and under Community the BuddyPress options will be displayed. To change this would require some custom code work. You can have a look at /bp-magazine/includes/main-navigation.php. Here you would be able to change the title of Magazine (line 8) and so forth.

    2- Summary posts on pages do not show the featured images. I am sure that I added featured image at each post... bug??

    When looking at the theme options under WP admin dashboard » Appearance » Theme Options » Homepage settings you will see the option to set the size of featured image and post page images. If your images are larger than the specified size it will automatically be cropped or it won't display.

    3- The "home" page is set to rotate thru available posts. There is only one post shown in the rotator... bug??

    You can specify the category for the posts that should display. Once again, you can set this by going to the theme options under WP admin dashboard » Appearance » Theme Options » Homepage settings.

    If you would like to provide me with a screenshot of the theme settings I can have a closer look at the settings to see what might be out of place.

    Look forward to your feedback.

    Have a good weekend!

    Gina

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.