BuddyPress Member Profiles lost directory or .htaccess

Hi, I have a problem I cannot solve and it is preventing me finishing the site for a presentation

I am running WP 3.1.1 and Buddypress 1.2.8 on Bluehost.com

The web address is http://www.irrilium.com/SecretPlan

Up until last week the build was going well. Sunday I began to get problems with profiles. I can navigate to the members page but on selecting a member or avatar to go to their profile or, when selecting profile from the BP nav bar I got server error 500.

I tried various fixes including renewing the .htaccess file and refreshing Permalinks. This didn’t resolve the problem. When I contacted Bluehost they reported it was a error 400 problem and the directories the selected URL was looking for did not exist.

To cut a long story short I asked Bluehost to restore a previous version of the site which was functional.

However, I am now back to where I started from even though the backed–up site which was used as the restore had been functioning perfectly.

So I am lost and need your help.

This is the current state of the site

.htaccess

# Use PHP5 Single php.ini as default

AddHandler application/x-httpd-php5s .php

Error log from this a.m.

Sat Apr 30 03:14:39 2011] [error] [client 66.147.244.160] File does not exist: /usr/local/apache/htdocs/wp-app.php

[Sat Apr 30 03:14:44 2011] [warn] RewriteCond: NoCase option for non-regex pattern ‘-f’ is not supported and will be ignored.

[Sat Apr 30 03:14:50 2011] [error] [client 95.108.246.253] Failed loading /usr/lib64/php/zend/ZendOptimizer-5.1.so: /usr/lib64/php/zend/ZendOptimizer-5.1.so: undefined symbol: zend_unmangle_property_name_ex

[Sat Apr 30 03:14:53 2011] [error] [client 66.249.68.245] PHP Warning: PHP Startup: Unable to load dynamic library ‘./magickwand.so’ – ./magickwand.so: cannot open shared object file: No such file or directory in Unknown on line 0

[Sat Apr 30 03:14:56 2011] [error] [client 66.249.68.53] PHP Warning: PHP Startup: Unable to load dynamic library ‘./magickwand.so’ – ./magickwand.so: cannot open shared object file: No such file or directory in Unknown on line 0

[Sat Apr 30 03:14:58 2011] [error] [client 66.249.68.245] PHP Warning: PHP Startup: Unable to load dynamic library ‘./magickwand.so’ – ./magickwand.so: cannot open shared object file: No such file or directory in Unknown on line 0

[Sat Apr 30 03:15:03 2011] [error] [client 66.249.67.52] PHP Warning: PHP Startup: Unable to load dynamic library ‘./magickwand.so’ – ./magickwand.so: cannot open shared object file: No such file or directory in Unknown on line 0

[Sat Apr 30 03:15:04 2011] [error] [client 99.23.248.81] Invalid method in request x807x01x03x01

[Sat Apr 30 03:15:04 2011] [error] [client 99.23.248.81] File does not exist: /usr/local/apache/htdocs/501.shtml

[Sat Apr 30 03:15:05 2011] [error] [client 99.23.248.81] Invalid method in request x807x01x03x01

[Sat Apr 30 03:15:05 2011] [error] [client 99.23.248.81] File does not exist: /usr/local/apache/htdocs/501.shtml

[Sat Apr 30 03:15:18 2011] [error] [client 99.23.248.81] Invalid method in request x807x01x03x01

[Sat Apr 30 03:15:18 2011] [error] [client 99.23.248.81] File does not exist: /usr/local/apache/htdocs/501.shtml

[Sat Apr 30 03:15:18 2011] [error] [client 99.23.248.81] Invalid method in request x807x01x03x01

[Sat Apr 30 03:15:18 2011] [error] [client 99.23.248.81] File does not exist: /usr/local/apache/htdocs/501.shtml

[Sat Apr 30 03:15:27 2011] [notice] cannot use a full URL in a 401 ErrorDocument directive — ignoring!

[Sat Apr 30 03:15:29 2011] [notice] cannot use a full URL in a 401 ErrorDocument directive — ignoring!

PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/local/lib/php/extensions/no-debug-non-zts-20060613/ixedts.lin’ – /usr/local/lib/php/extensions/no-debug-non-zts-20060613/ixedts.lin: undefined symbol: executor_globals_id in Unknown on line 0

[Sat Apr 30 03:15:35 2011] [error] [client 66.249.68.2] PHP Warning: PHP Startup: Unable to load dynamic library ‘./magickwand.so’ – ./magickwand.so: cannot open shared object file: No such file or directory in Unknown on line 0

[Sat Apr 30 03:15:45 2011] [error] [client 66.249.68.1] PHP Warning: PHP Startup: Unable to load dynamic library ‘./magickwand.so’ – ./magickwand.so: cannot open shared object file: No such file or directory in Unknown on line 0

[Sat Apr 30 03:15:50 2011] [error] [client 157.55.16.229] PHP Warning: PHP Startup: Unable to load dynamic library ‘./magickwand.so’ – ./magickwand.so: cannot open shared object file: No such file or directory in Unknown on line 0

[Sat Apr 30 03:15:53 2011] [error] [client 66.249.67.242] PHP Warning: PHP Startup: Unable to load dynamic library ‘./magickwand.so’ – ./magickwand.so: cannot open shared object file: No such file or directory in Unknown on line 0

The Buddypress plugin directories present

bp-activity

bp-blogs

bp-core

bp-forums

bp-friends

bp-groups

bp-languages

bp-messages

bp-themes

bp-xprofile

Other plugins in use

Akismet

BP Group Calendar

BuddyPress Custom Posts

BuddyPress Like

BuddyPress Profile Music Widget

Buddypress Sidebar

Buddypress Sitewide activity widget

Chat

Cimy Rotating Header

CustomPress

Easy Albums – Buddypress users create and share images, video and audio albums – the easy way.

GD Star Rating

Login Image

Mail From

MarketPress

MP3-jPlayer

Signup TOS

Welcome Pack

I appreciate that it’s the weekend and I am on London time so let me know if you can help when you can.

Steve

  • Mason
    • DEV MAN’s Sidekick

    Hiya Steve,

    That’s no fun. Looks like a documented PHP bug:

    http://forums.cpanel.net/f5/undefined-symbol-sqlite3_libversion-148993.html#post632357

    Find out what version of PHP you’re running (this one appears to have started in PHP 5.3.2). Here’s the bug report: http://bugs.php.net/bug.php?id=48614

    BlueHost should either run a patch or downgrade (and they really should have already been aware of this – as it’s been noted for over a year).

    That’d be my first step with this. Once you’ve got that sorted, if there’s still an issue we can look at the WordPress/BuddyPress plugins.

    Thanks!

  • steve kelsey
    • WPMU DEV Initiate

    Hi Mason,

    Looks like bluehost are on 5.2.17 and are not looking to 5.3 for a while.

    One thing at a time on this but I got a message from an unknown on the Buddychat plugin on the 26 th April, so I would like to look at how I bloke this once I am back up and running.

    Today I am going to work through the active plugins deactivating them to see if there are any misbehaving. I will update you one that has been completed.

    Steve

  • steve kelsey
    • WPMU DEV Initiate

    Hi Mason.

    Well I have it working again but I am not sure if I solved the underlying problem.

    Xprofile started working again after I deactivated PaulSmith’s Welcome Pack plugin.

    Once I was sure all was well I reactivated this pluging expecting to trigger the smae problem but both are working. Odd!

    I had a similar problem with the Eventpress plugin. The Eventpress plugin reverted to normal behaviour after I deactivated the WPMU CustomPress plugin.

    Once I was sure Eventpress was working properly I reactivated CustomPress expecting to see the same problem but no,both are coexisting nicely.

    All very very odd – and I suspect a hosting setting hosting error which has been correct.

    I would like to understand what happened as I hate the thought of the site being fragile but for now it’s all up and running as designed.

    I promise not to bug you unless it recurs at some point.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.