Buddypress MultiSite Subdomain Config

Hi All,

Need some help to troubleshoot why Multisite config is failing to allow admin access.

Site creation works fine:
http://skills.traderstouch.com/

However, I have no way to access the admin or dashboard - even logged in as SuperAdmin.

I setup the network using the subdomain configuration that requires creating the * wildcard A record.

I am able to add sites,

I have gone through many different checks, including:
- checking my .htaccess file
- Cpanel - ADD SUBDOMAIN *.traderstouch.com
- turned off all plugins

Not sure what else I can check or if others have had similar experience.

Looking for any suggestions to troubleshoot.

Thanks!

kampester

  • aecnu
    • WP Unicorn

    Greetings kampester,

    Thank you for this great question and bringing this significant issue to our attention.

    I just visited the site at http://skills.traderstouch.com/ and was able to get right to the log in screen without any issue, of course I do not have log in information so I was obviously not able to log in.

    Have you tried bringing this site up in a different browser?

    Have you reset your permalinks to anything but default?

    And what about the htaccess file?

    Please advise.

    Cheers, Joe

  • kampester
    • Flash Drive

    Hi Joe - thanks for the quick response, and as you stated I can visit the wp-login page of the installed child blog, however no passwords work for access.

    I have attempted the following logins:
    1) Access ChildBlog Dashboard via Nework Dashboard as SuperAdmin - FAILED

    2) Access ChildBlog wp-login as SUPER ADMIN - FAILED
    http://skills.traderstouch.com/wp-login.php

    3) Created NEW user on ChildBlog - upgrade to ADMIN - and attempted to Login via wp-login form -- FAILED

    I repeated the above will all plugins turn off and was not able to access.

    Here are the details of my wp-config and .htaccess files:

    define('WP_DEBUG', false);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'www.traderstouch.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    
    /* That's all, stop editing! Happy blogging. */
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress

    From my research it appears these settings should be all fine, but I am thinking that I must be missing something.

    I attached my WHM and CPANEL configurations for setting A record and the wildcard subdomain, respectively.

    Again, any direction would be great!

    Kampester

  • kampester
    • Flash Drive

    Still looking for some insights to troubleshoot this access problem to my subdomain.

    When I try to access the dashboard for the new subdomain site, from the Network admin panel... I get this URL redirect:

    http://skills.traderstouch.com/wp-login.php?redirect_to=http%3A%2F%2Fskills.traderstouch.com%2Fwp-admin%2F&reauth=1

    What does the reauth=1 mean? I am thinking that somehow permissions are not set correctly.... but I have no idea where to start?

    Ideas?

    Thanks

    Erik

  • kampester
    • Flash Drive

    Still working on this problem...

    Nothing seems to work. I re-test turning off all plugins and still nothing works

    Hoping to get some direction - can anybody provide insights on editiing the DB directly to modify permissions? THis seems to be a user-access issue.

    THanks Erik

  • Tom Eagles
    • Syntax Hero

    Hi there, I had this exact problem a few days ago. I went through every single permutation of plugins etc, enabling disabling, 3 total re-installs. I had used the softalicious install on my host with mu support. I just then went in and added the sunrise.php etc. domain forwarding etc. all looked perfect. BUT i couldnt login.

    Everytime i tried to login on the main super-admin account i just got the WP login box re-appear without an error message. My setup is identical to yours.

    So i contacted my host they said all was good, contacted softalicious who reinstalled all for me, and sent me screen shots of the wp-admin pages after they had logged in.

    So got back in contact with my host to see if my ip had somehow been blocked. No all was good.

    AND here was the solution CACHE in my browser!!! I just cleared everything from all browsers, cookies, cache. hostor you name it cleared the lot.

    And then bingo i got in straight away on the main domain, created a few subdomain test sites all worked.

    Not saying this will help in your case but give it a go, after banging my head afainst a brick wall for 24 hours straight, a simple browser issue was the problem,

  • aecnu
    • WP Unicorn

    Greetings kampester,

    My sincere apology that you were not tended to while I was on vacation and upon my return it also appears that one of the staff members assigned to take over my duties is no longer with WPMU Dev.

    This is certainly not standard protocol and Murphy seems to have had his input in here as well.

    However, has the suggestion that tom.eagles pointed out above concerning clearing your cache perhaps helped resolve your issue by any chance?

    If not what about caching on the server side? Are you running caching there in your WordPress installation by any chance?

    Once again my sincere apologies for what seemed to be abandonment but is in fact an issue of timing and circumstances.

    Sincerely, Joe

  • kampester
    • Flash Drive

    @tom.eagles thanks for the follow up and suggestions, just when I was giving up you guys offered up suggestions and tips... wow, that's amazing.

    @Aecnu, thanks for chiming in. That alone speaks greatly, shit happens, I get that.

    I left the issue open, I needed an alternative solution and will try to reexamine my setup and report back here.

    Thanks All!

    kampester

  • aecnu
    • WP Unicorn

    Greetings kampester,

    Thank you for your additional feedback it is appreciated of course to include your understanding of the circumstances.

    I certainly want to see you get this going and if necessary I will do a reinstall of the MultiSite for you to get this off the ground and to show our sincerity for the delay in helping you get this going.

    Please advise how you make out and if you want to take the drastic measure of a re-install done by us.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings kampester,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

  • kampester
    • Flash Drive

    Hi Aecu

    I attempt to retrace my troubleshooting steps and include suggestions made here, Nothing seems to work.

    My attempt to modify my domain settings in cpanel.as @tom.eagle suggest resulted in cashing the new subdomain - error msg "internal config error" - see attached image.

    With the new "document root" I get a blank index page - Index of /

    Do I need to add the new subdaomin: skills ?
    http://skills.traderstouch.com/

    I thought the * wildcard is suppose to capture this,

    SO the issue remains a mystery. Right now I am in the middle of a marketing campaign so reinstalling this site right now is not an option.

    I was hopping the issue was a simple misconfig in one of my settings. Unless there are some other tweaks try...

  • Tom Eagles
    • Syntax Hero

    here is what i see so the wildcard is working.

    I had a problem with my host when i had a wildcard domain entry and two subdomain entries as you have in the end i had to delete the two subdomain entries and let the wildcard handle them all

    have you tried just as a test adding a new user to that page?? then logging in or try to create a new superadmin account and log in with that one.

  • kampester
    • Flash Drive

    @tom.eagles - thanks for checking in. I appreciate it big time!

    I thought I posted my results here yesterday - appears I have to repost - oops!

    No luck so far.

    I deleted the 2 other subdomains and left the wildcard - this did not work. As you stated the site-dispalys, however I have no admin access.

    Not sure what is left to do.... but I will be ready to try any other suggestions.

    Cheers

    kampester

  • PC
    • WPMU DEV Initiate

    Hiya @kampester,

    Greetings. Just chiming in to see if I can help !

    Can you please send me the network and cpanel login credentials to pc then at then incsub.com so that I can have a look at the settings.

    Also please tell me what not to touch in that.

    @tom.eagles : Thanks a lot for your super support on this one.

    Cheers
    PC

  • kampester
    • Flash Drive

    Thanks PC - I just emailed you to login info. - Look forward to hearing what I missed. I have al;ready disabled all plugins and tried from a clean start. The last step is to do a clean re-install.

    Hope you will find something simple, I over looked !

    Kampester

    p.s. @tom.eagles thanks for you guidance and support!!! This community does rock!

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    Your setup looks correct to me, but you are running a WordPress install that's nearly a year old. In internet years that's a dinosaur. I'd highly recommend for both stability and security that you update to the latest versions of WordPress/BuddyPress and any other active plugins you have.

    If that doesn't fix things for you, then try deactivating s2 members (just momentarily) and see if you can access the sub-site admin. s2 says it has to "patch" the WordPress core after each update. I have no idea what that does, but that could also be the culprit here.

    I do believe the problem is something within WordPress (out of date or bad plugin) and not your server setup though.

    Hope this helps.

  • kampester
    • Flash Drive

    @mason great stuff...the update seems to have fixed the issue!

    - I think @PC got int there to make it all current, so Thanks WPMDEV and community! You guys rock.

    The last update on the wp core was in April--May,...so my best guees is that I had a miss config on the servers back then, and the most recently as I upgraded the plugins but left the core things got misaligned. Regardless, it looks like I have much better understanding of how wordpress works!

    Cheers - kampesters!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.