BuddyPress No "Register" Page!

I've not done anything crazy with this new site I'm building.

Enabled Network in Wordpress after I installed it.

Uploaded and am using a BuddyPress theme, from WPMU Dev (Studio Theme).

Installed and activated both Membership plugin, as well as BuddyPress.

But for some reason, if I go to Sign-Up/Join, as a user would -- the page cannot be found.

What am I missing??

Here's the site as at appears today: http://whogotnextnow.com/

Thanks for your help, in advance.

  • DavidM
    • DEV MAN’s Mascot

    Hello bpublic,

    I believe that's due to the BuddyPress requirement for pretty permalinks! If you'd navigate to your Settings > Permalinks page and select from one of the other options besides the default, I believe it should work perfectly for you from there!

    Cheers,
    David

  • Timothy Bowers
    • Chief Pigeon

    Have you checked your htaccess file to make sure everything is OK there?

    Because all your permalinks are down : http://whogotnextnow.com/blogs/ http://whogotnextnow.com/activity/ it is most likely a htaccess issue.

    When you enabled Multisite, did you make the require htaccess changes?

    Take a peek at: http://codex.wordpress.org/Create_A_Network#.htaccess_and_Mod_Rewrite

    Also try using the default theme and deactivate other plugins to make sure there are no conflicts.

    Let us know the outcome. :slight_smile:

  • bpublic
    • Flash Drive

    Thanks for responding.... this doesn't look right, but I'm not sure what it should look like:

    # -FrontPage-
    
    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*
    
    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName whogotnextnow.com
    AuthUserFile /home/whogotne/public_html/_vti_pvt/service.pwd
    AuthGroupFile /home/whogotne/public_html/_vti_pvt/service.grp
  • Timothy Bowers
    • Chief Pigeon

    No that is not right, if you looked at the link I provided it gave two examples for you:

    Sub Folder:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    And sub-domain:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress

    It doesn't work in all environments, but works for most.

  • Timothy Bowers
    • Chief Pigeon

    You are very welcome!

    I'm sorry, I read your response last night and forgot about the link to the examples and when I wrote back today, I went from memory when I should have re-read it!

    You don't need to be sorry! We all need a little guidance sometimes. :slight_smile:

    Glad to hear it is all sorted now!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.