Buddypress Redirect issues - very odd..

I've got a very, very odd redirect issue... when clicking on my activity page, I'm automatically sent to the homepage...

I've checked slugs (I read somewhere that can cause problems) and they're all unique....

It's also only just started to happen... I've not installed any plugins... all I did do was move the menu's around using the social plugin menu thingy...

So I put the menu's back how they were - and still get the problem. All other pages are behaving properly.

Thanks,
Rob

  • Timothy Bowers

    Hey Rob.

    Might be easier if I could whiteness the issue.... :slight_smile:

    Things I would double and tripple check:

    1. Using latest versions of WP and BuddyPress.
    2. BuddyPress pages are created and linked form the BP admin area.
    3. Go save those permalinks again to ensure they are working.
    4. Check the htaccess rules.
    5. I might also revert it to the default non-permalink - /?p=123 and test again
    6. If using custom menu then double check I hadn't done some link hard coding.

    Let me know if any of these help resolve the issue. :slight_smile:

    Take care.

  • rpwillie

    1. Using latest versions of WP and BuddyPress.

    Done

    2. BuddyPress pages are created and linked form the BP admin area.

    Done

    3. Go save those permalinks again to ensure they are working.

    Done

    4. Check the htaccess rules.

    Um... not sure what I'm looking for here... I'm such a noob!

    5. I might also revert it to the default non-permalink - /?p=123 and test again

    Done

    6. If using custom menu then double check I hadn't done some link hard coding.

    Yep - no hard coding... I've even disabled the custom menu... and still get the issue.

    Still get the issue... very puzzled by this, because it was working...

    Cheers,
    Rob

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.