BuddyPress will not allow avatar croping or updating

No matter how many times I try, I cannot change, add or crop a new avatar image BuddyPress profiles. I updated an image for my WordPress.com profile (see here in my WPMU Dev Profile) and it picks up that image and refuses to replace it with anything else. How can I correct this?

  • Ash

    Hello @Eden

    Welcome to WPMU community!

    I hope you are well today and thanks for asking the question.

    Do you have any other avatar related plugin installed? If yes, please deactivate and check.

    If not, please check with default WP 2012 theme and if it works, then it's an issue with your current theme.

    And then, would you please enable debug mode and check if any error is shown in that page?

    To enable debug mode please edit a line in your wp-config.php:
    Change

    define('WP_DEBUG', false);

    to

    define('WP_DEBUG', true);

    Try to add an avatar and check if any error is shown.

    Finally, right click on chrome browser > inspect element > select console tab > refresh the page > try to add an avatar and see if any error is shown in the console tab.

    Please let us know how it goes.

    Cheers
    Ash

  • Eden

    i cannot simply change the whole theme to test it with something else. My site is live and I have users on it. I will not risk freaking people out while I'm still trying to establish a rapport with my members.

    I have carefully gone through all my plugs in a third time to ensure that there is no other plugin still active which may be effecting the avatars. Everything else has been deleted and deactivated.

    When I upload a photo although the cropping easily glides in any direction over the image for a selected cropped area, the preview window only show results that are slightly higher or lower in direct vertical positions above or below the initially displayed, sample cropped image preview. when I've selected an area to crop and press enter, I get this error message:

    "There was a problem cropping your avatar." It does not say why or give any hint as to where to look to correct the problem.

    I am using the WP-Bold theme and there is no wp-config.php

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.