bug: BP-Social theme. Admin panel options blank

Using bp-social theme. In WP admin the theme options don't show, only the 'save setting' button. So I can't change any settings.

Options are set in wp_options table.
If I wipe wp_options table it fixes the problem. However, I have several large plugins and I don't want to have to re-install them all and re-set all the settings.
Have tried deleting theme and re-install - still broken. It isn't one of the obvious settings - as I've deleted these by hand from wp_options - still broken.

Any ideas please.
Thanks.
community.weloveourlocals.co.uk

  • Alexander

    Hi @mike_morris,

    Do you know what I could try to reproduce the issue? I've tried changing settings and playing with them, but the options are always there.

    If you'd like to remove manually: In the wp_options table, all the Social options are prefixed with: tn_buddysocial_ You could try deactivating the theme, then deleting these rows.

    If you're using phpMyAdmin, be sure to sort by "option_name" Not all the options were created sequentially, so it might be hard to find them all sorting by id.

    Thanks for being a WPMU DEV member. Let us know if we can be of any further assistance.
    Best regards,

  • Mike

    Sorry to sound pedantic, but if I knew how to re-create it I'd know what caused it and could fix it...

    All I know is that it was ok. Now it isn't. Alas, in between I installed Membership Plugin, Classifieds, Directory and others. I had no cause to check the theme so can't say when it died.

    All I can say is that total removal of the theme - total removal of all theme related wp_options entries - and re-install won't fix. At that point the theme will no longer write it's options to the table at all.
    Then I just pull in an old SQL export to manually insert theme options into DB table. But I can't change them from WP admin panel, only phpmyadmin.

    Only fix I've found is roll-back to fresh install - but that would mean setting up all my plug-ins again.

    This suggests to me that a corrupt entry has been created in wp-options - and that bp-social tries to write to it. Since a single failure aborts all current DB operations (I think) that might be enough to prevent ANY theme options being written?

    I know little, this is just a guess.

    Here's the screen - and the table, just in case.
    (On a total side-note. Can you tell me why the SQL export adds in all the cr*p and posts from the wordpress.org blog - when it's not referred to at all in the table? really annoying!)

    Thanks

  • Alexander

    Well, before we get too deep into messing with the SQL, let's see if we can raise any errors that will give us a hint to what's going wrong. If the theme options page is breaking, perhaps we can get it to provide an error with specific info.

    First, can you please enable debug mode?

    Next, let's check for JS errors. In Chrome go to "View -> Developer -> Javascript Console" and in Firefox you can go to "Tools -> Web Developer -> Console" Try using the theme options page and clicking around with the console open. Let me know if you run into any error messages.

    And finally, if you're not seeing any errors in the dashboard, a particularly good way to find SQL errors is to enable debug logging. We have a great tutorial on this posted by one of our members here: https://premium.wpmudev.org/forums/topic/the-right-way-to-debug-php-in-wordpress

    Let me know what you find out.

    Best regards

  • Alexander

    @mike_morris,

    Thanks! Let's see what we can find here. It's likely that one of your plugins is causing a conflict with the script used in the theme. This may have even caused improper values to be saved to the database at one point.

    Can you see if you get this error on any other pages in dashboard?

    Also, try switching to a different theme and see if the error remains. If it's still there, we could have a plugin conflict.

    Can you try deactivating any of your other plugins? You can just start from a matter of least importance.

    Let's see if we can track down what's causing this error, and go from there. Let me know what you find out.

    If you'd like I could login to take a look as well, just let me know and I can tell you how to get in touch privately.

    Best regards

  • Mike

    @Alexander Rohmann

    Thank you very much Alex, your're 2 for 2 so far!
    Stupid of me really, I never thought to disable plugins - had it stuck in my head they only break the front end.
    I disabled all the plugins, intending to switch each on in turn. Theme options came back - good start. But even after re-enabling all plugins they remain working!? So I'm guessing maybe a plugin update has fixed but needed disable/enable to force the fix? Or that a plugin was trying to use the same record as theme options and off/on forced it to create a new record.

    Whatever, now it's not broke I can't fix it! Just the forum to fix and I'll be happy as a clam.

    Sending an imaginary sticky bun as a thank you. (mmm, lemon and blueberry!)

    Best
    Mike

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.