Bug can't translate one string

Hi,
i am trying to translate the blog_templates.po but one of the string gives me error! not matter what i try to put it gives me this error (attached screenshots).

the string is:

Create a blog template based on the blog of your choice! This allows you (and other admins) to copy all of the selected blog's settings and allow you to create other blogs that are almost exact copies of that blog. (Blog name, URL, etc will change, so it's not a 100% copy)

  • Adam Czajczyk

    Hey Ruslan,

    I hope you're well today and thank you for your question!

    The errors you receive mean that the particular string has been market by the developer as php-format string in .p file. It results in giving some characters (like %) a special meaning. Now, according to your first screenshot, you didn't use % in your translation so there's no required variable given. On the other hand, error from example from your second screenshot says that you didn't format the translation properly.

    Judging by the original message text itself it might be a bug indeed, so I'll ask the developer about it. For now, an easy workaround would be to copy the original string first and then edit it.

    In the "Source text" box right-click on the message to translate and select "Copy from source text". The string will be copied into the "Translation" box. You can rewrite it now to your language and if you'll simply omit the "100%" part there should be no errors.

    I hope that helps,
    Cheers,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.