Assign Capabilities under Settings

I believe there is a bug in Assign Capabilities under Settings because even though I selected "Subscriber" but it changes back to "Administrator" by itself.

  • MG2068
    • WPMU DEV Initiate

    It selects the "role" fine, based on that all the options beneath also gets reflected (checked & unchecked) and once I click Save, it acts as if it saves properly too but when I go to another option in Wordpress and then comeback to QA plugin's settings, it shows "Administrator" role again with everything checked.

    Hope this helps!

  • James Farmer
    • CEO (of WPMU DEV, honest)

    Hi Guys,

    Just a quickie, but wanted to let you know that we've taken a bunch of people off other projects to massively improve Q&A as quickly as possible.

    This is gona involve some better UX, some seriously improved design and compatibility elements and looking into and fixing up as many bugs as we can.

    Am posting this on all the latest threads so everyone is aware where we're at, sorry for doubles.

    Just want you to know that we hear ya and will have stuff sorted asap!

    Cheers, James

  • Hakan
    • The Incredible Smush

    Hi,

    I think there is a misunderstanding here.

    "Assign capabilities" selection includes several roles and its related capabilities.

    it acts as if it saves properly too but when I go to another option in Wordpress and then comeback to QA plugin's settings, it shows "Administrator" role again with everything checked.

    This is quite normal as Administrator has all the capabilities and it is the role on the top.

    What happens when you change the selection to Subscriber?

    Then the capabilities of subscriber are not correctly shown?

    Cheers,
    Hakan

  • MG2068
    • WPMU DEV Initiate

    What happens when you change the selection to Subscriber?

    It acts as if it saves properly with Subscriber-related check-marks but when I go to another option in Wordpress and then comeback to QA plugin's settings, it shows "Administrator" role again with everything checked.

    Then the capabilities of subscriber are not correctly shown?

    No. I think as @James mentioned, this plugin needs UX immediate improvement, both front-end and back-end!

  • Hakan
    • The Incredible Smush

    Hi everybody,

    This wasn't a bug. Never had been a bug. It was just a very minor display issue for a few people, not even for me.

    It never prevented you to set your roles as you wish. But it didn't display the latest selected role. So what?

    As of V1.4, the latest edited role is pre-selected now, but once again, it does not improve or make it worse anything in role settings. Because there was nothing to be fixed.

    I am closing this thread as it is resolved, or there was nothing to be resolved but it is more intuitive now.

    I am also editing this topic title because in no way this can be regarded as a "bug".

    Cheers,
    Hakan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.