Bug: Latest Update Removed All My Dashboard Widgets in Easy Mode!

This is strange... In Standard Mode, I see all the dashboard widgets I want without a problem. (I'm using Custom Dashboard Widget + Dashboard Feeds Plugins and only showing those widgets).

However, in the Wizard Mode and Easy Mode, my dashboard is completely empty. When I see what options are available in the Screen Options drop down, I only see an option for the Welcome nag. Everything else is gone...

So I went over to the Easy Blogging Dashboard Items settings to see if that could be the culprit.

I see this checkboxes for these items:

[box w/ no description]
[box w/ no description]
Old title for Custom DB widget
[box w/ no description]
[box w/ no description]
[box w/ no description]
Recent Updates (a old 3rd party feed widget I no longer use)
[box w/ no description]
[box w/ no description]
[box w/ no description]
[box w/ no description]
Affiliate Report (affiliates plugin)
The Latest News From Range (twitter pro plugin i disabled)
Blubrry PowerPress & Community Podcast (powerpress plugin)
Blubrry Podcast Statistics
Site Stats (jetpack)
OptimizePress Updates (feed from OP)

I made sure EVERYTHING is unchecked to make sure nothing is hidden...

Still didn't fix it.

By the way, how do I remove these OLD widgets that I don't even use anymore - some of their plugins not even active, and others I modified the plugin to completely take out the dashboard widget... (feature request - to clean up inactive entries?)

Please advise!