Bug related to update-notifications.php - wrong installed version reported

On my dashboard update-notifications.php is reporting its version as 3.0.4 instead of the correct version (which is installed) as 1.0.4.

I debugged this and found that the version being reported for update-notifications.php is
actually the version found in the header of db.php (Multi-DB). When I change the version in db.php it appears as the version for update-notifications.php in the dashboard!

Note that Multi-DB version information doesn't appear at all in the Dashboard.

Here is what my Dashboard looks like under Super Admin->WPMU DEV.
Note that the other strange item is that Ad Widget reports as version "2.0" while the latest
version is "2".

Installed Plugins/Themes
Name Installed Version Latest Version
Ad Widget 2.0 2
Anti-Splog 1.0.5 1.0.5
Blogs MU Theme 1.2.2 1.2.2
Easy Blogging 1.1.2 1.1.2
Easy Blogging Tooltips 1.1 1.1
Easy Blogging Wizard 1.0.1 1.0.1
Simple Ads 1.0.1 1.0.1
Update Notifications 3.0.4 1.0.4

Scott