Bug - Text Boxes Unfillable in CoursePress

I started using CoursePress Pro for the first time today. However, I immediately hit a bug. When I chose "new course" I could fill out the name fine, but the "Course Name/Short Overview" was unfillable. When I clicked on the box nothing happened, and as it is a required field it wouldn't let me go to the next part. After going in and out several times suddenly it accepted text and I got to the next stage. I am now trying to set up some multiple choice questions but the "question" field has exactly the same problem, it often won't let me fill anything. Occasionally it accepts text (if I click on something else then go back in), but most of the time it is unresponsive.

This bug is not a complete show stopper but it's very irritating and wastes a lot of time. How can this be fixed?

Iain

  • Michelle Shull

    Hello Iain! Happy Sunday!

    This sounds like it may be a plugin conflict. Can you try disabling your other plugins and see if the issue persists?

    I'd lean towards either a page builder, caching, or a security plugin first, but plugin conflicts don't always make sense on the surface, so it's worth checking all the plugins you have installed.

    Let me know how this check goes! Thanks for your question.
    : )

  • Iain

    I think you were right, it was a plugin conflict.

    I disabled all the plugins and noticed that seemed to solve the problem (after deactivating and reactivating Coursepress), although the question text box had become enormous and there was a mysterious clickable letter "p" in the bottom left of it, which did nothing when clicked. I could now enter text though, which solved the main issue. Then it was just a case of going through all the plugins, reactivating them and waiting to see which one was doing the damage. It turned out to be a shared whiteboard plugin I was planning to use during lessons. It's disabled now and all seems well, although the "question" box in the units section still seems way too big and the letter "p" at the bottom doesn't look like it should be there.

    Anyway, for now it seems at least mostly solved, I'll keep using it and see if any other problems develop.

    Thanks,
    Iain

  • Iain

    Ok, here's some screenshots.

    There aren't really any weird elements, it just behaves a little differently depending on different factors. Hopefully the images all attached OK.

    Image 1 shows what happens when the offending whileboard plugin is activated and a new question is created. Notice that there is a small box within the main textbox, and it accepts text.

    Image 2 is still with the whiteboard plugin activated but when I try to edit an existing question. Notice there is now just a single textbox and it is unclickable. The text has also disappeared.

    Image 3 is with the whiteboard plugin disabled. This is the situation when both creating and editing a question. Notice the textbox has become much bigger, a "p" has appeared at the bottom and there are a lot more options. Actually I suppose this is the way it is supposed to look, but I had got used to the smaller box so it just looked odd when it first started appearing this way.

    Anyway, what's clear is that the free "Shared Whiteboard" I downloaded is messing with Coursepress.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.