Bug with Appointments + Settings Tabs

Hey,

Just downloaded the Appointments + plugin, which looks pretty great so far except for one small issue. In the settings page, I can't click on the tabs at the top of the page, to switch to different tabs like "Services" or "Service Providers." More specifically, I can click on them, but it doesn't actually take me to those tabs, it just leaves me on the default settings page. I can input the URL in my browser to switch tabs, so it's not totally unusable, but it is a weird bug to be having. I tried using a different Internet browser and the issue was still present.

Just thought I'd mention this, hopefully you can help me figure it out.

Thanks,
Jordan

  • Patrick

    Hi @Jordan

    Welcome to the forums!

    That type of behavior is usually caused by a script conflict with another plugin, or even the options panel of your active theme.

    Basic troubleshooting protocol should be followed to locate the possible conflict.

    Revert to a default WordPress theme (Twenty-Twelve or Twenty-Thirteen). Is the problem still there? If the answer is no, then it's a theme conflict. If it is still present...

    De-activate all plugins. Then re-activate them one by one, and test with each activation until you find the problem plugin.

    Once we've zeroed in on the possible cause(s) of your issue, we'll be better equipped to deal with it.

  • Jordan

    Hey Patrick,

    Thanks for the quick response. Honestly it's probably not a big enough issue to go on a troubleshooting mission at this point, but I appreciate the input as to what process I should follow in order to begin fixing things if necessary.

    Another question I have for you regarding the plugin: Is it actually necessary to create a new WordPress user for every new service provider I need, even if they are dummy service providers? The only reason I ask is that right now I don't actually have any service providers working for me, so in order to play around with the plugin and use multiple providers, I'm going to have to generate new email accounts for each user that I need to create. Is there any way around this?

    Thanks for your help,
    Jordan

  • Jordan

    A few more questions: Is there a way to quickly create an already set-up appointments page, without having to input all of the short codes? I only want to display appointment availability for the same-day on the calendar, not any days in the future. Is this possible? Is there any way to adjust the font that pops up when using the scheduling short codes? The default font is quite small, and doesn't really fit with my website.

    Sorry for all of the questions, I'm just having a more difficult time with using the plug-in than I thought I would.

    Thanks,
    Jordan

  • Jordan

    As an update, I seem to have figured out how to get the already set-up appointments page, so that question no longer needs answering. However, an additional issue popped up. For some reason, even though I changed the setting to only require one hours notice to schedule an appointment, the earliest time the calendar will let me choose is 6PM, despite it being only 1:48PM EST right now. Is this due to a time zone issue, or something else?

  • Patrick

    @Jordan

    I'm going to have to generate new email accounts for each user that I need to create. Is there any way around this?

    Sure. You can use existing users. Or create new ones under Users > Add New and use your webmail address like so: newuser@yoursite.com

    Is there any way to adjust the font that pops up when using the scheduling short codes?

    That depends on your theme. There are no built-in options to adjust the font-size, but that can be adjusted with a bit of custom CSS added to your theme's style-sheet.

    the earliest time the calendar will let me choose is 6PM

    That is possibly due to the working hours not being fully adjusted for all service providers, including the no preference option. Please double-check your working hours settings.

  • Jordan

    That is possibly due to the working hours not being fully adjusted for all service providers, including the no preference option. Please double-check your working hours settings.

    It doesn't seem like this is the problem, as I had checked that before I messaged you regarding the issue, and after checking again just now to reconfirm, the availability is set from 8AM to 10PM for every service provider on every day. Also, when I checked back on my appointment page at 4:31PM, it would only let be book an appointment at 9PM, so it seems to be an issue with time zones or something other than service provider availability.

    Sure. You can use existing users. Or create new ones under Users > Add New and use your webmail address like so: newuser@yoursite.com

    In speaking with Mike, one of your sales guys, he said this: "You shouldn't need to create a new user account for each service provider as it should be a dummy account for a service provider." Maybe he's just not 100% certain on how this feature works, but I wanted to just confirm with you whether or not this is possible.

    Finally, I had mentioned in one of my previous posts that I only want to display appointment availability for the same-day on the calendar, not any days in the future, but right now when I set the settings to only display 1 day in advance, it shows my schedule up until part way through the next day. Is it possible to modify this so that only appointment availability for the same calendar day is displayed?

    Thanks,
    Jordan

  • Jordan

    Another issue that just popped up: Is there a way to allow this plugin to be responsive? My website theme is responsive and looks great on my phone, but when I look at the page with the plugin on my phone, the plugin doesn't scale and it's practically unusable, as you can't see the entire appointment scheduler. Is there any way to modify this, as this is quite an important feature for me.

    Thanks,
    Jordan

  • Patrick

    @Jordan

    Sorry for the delay in responding: I had a splitting headache yesterday and took some needed time off.

    Let's first clear up the dummy user questions.

    Dummy users in Appointments+ do not need to be actual people. But they must be user accounts on your site. So yes, you do need to either use existing users, or create new accounts to use just with the plugin.

    The email address used for dummy users can be anything. I simply use username(at)mysite.com, and add them without sending a confirmation email. Once added, they are ready to use in Appointments+.

    As for the time offset issue, you may be right. Please ensure that both your WordPress site and server are set to the same timezone. Also, if you are using Gcal integration, be sure the timezone in your calendar is the same.

    We've also had reports of issues with BackWpUp plugin messing with time settings. Do you have that plugin installed?

    when I set the settings to only display 1 day in advance, it shows my schedule up until part way through the next day.

    If you set the upper limit to 1 day, the plugin will calculate a 24-hour period from the current time. So some bleed into the next day is to be expected. I don't know of any way to limit it to the current, or any specified day only.

    That would actually be a good feature suggestion. That way, you could have the choice between monthly, weekly, or daily calendars.

  • Jordan

    Hey Patrick,

    No worries, I actually had a bit of a headache yesterday too, so I totally understand.

    Thanks for clearing up the Dummy User question, that's a pretty easy workaround you provided, so that should work well.

    I also just fixed the time zone issue thanks to your message, because, great troubleshooter that I am, I never thought to actually check the time zone settings on my WordPress back-end. Sure enough, it was set to 4 hours ahead of EST, which I'm in, so that was a pretty easy fix.

    The 1 day in advance thing isn't the biggest deal in the world, but it definitely would be a nice feature to have daily calendars, at least for my business anyways. How would I go about suggesting that as a feature? Or are you the dev for this plugin?

    Finally, the only thing really left unresolved is the issue of this plugin's responsive capabilities. That's definitely a feature that would be ideal for me, as the plan is for my clients to be able to book from their mobile devices, and as it stands right now (at least on my device, a Samsung Galaxy Note 2), that wouldn't be possible. My website is fully responsive, but the page that the Appointment Scheduler is on is "zoomed in," so that you can only see the left portion of the page. Is there any way for me to tweak this so that it is more responsive? That's probably my biggest issue at the moment, everything else is basically resolved now. So thanks for that :slight_smile:

    Jordan

  • Patrick

    @Jordan

    Yay! Glad the time offset issue was a quick fix. That can be a real pain when servers don't cooperate. :slight_smile:

    As for the feature request, simply create a new topic with an appropriately catchy title, and post it to the Features & Feedback forum. And no, I am not the developer of this, or any other, of our plugins... I'm not a coder by anyone's standards... more of a tinkerer. :slight_smile:

    Now to the responsiveness of the calendar layout. As you have discovered: it ain't. It is fluid though, which means each side-by-side section will squeeze to fit the available screen width.

    So you could add a media query to your theme's style-sheet to pop the calendar and timetable to 100% on smaller viewports. The timetable would evidently open beneath the calendar though.

    @media screen and (max-width: 768px) {
    .app_monthly_schedule_wrapper, .app_timetable_wrapper { width:100%; }
    }
  • Jordan

    style.css is the file to put it in....

    At a glance, try changing that @ to a # , and see how that goes....

    :slight_smile:

    Ahh yes that would make more sense wouldn't it lol, thanks for pointing me in the right direction :slight_smile:

    Unfortunately, inserting the code into the style.css file didn't appear to do anything. I tried it both with an @ and with a #, and it didn't make a difference, the calendar is still only partially visible on the page on my mobile device. Anything else to try/tweak?

  • Patrick

    Unfortunately, the members who participated in this thread are no longer active.

    But for any others who happen upon this, the answer in this post above:
    https://premium.wpmudev.org/forums/topic/adding-more-fields-to-the-user-registration-form

    The CSS goes in the theme's style-sheet; usually style.css. But the actual name can vary from theme to theme.

    Or, one could use a plugin like Simple Custom CSS.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.