Bugs in CoursePress email messages

There are bugs in the emails. The image is for Enrollment Confirmation but there are problems in other emails too. About the space after Hi, could be because I do not have a first name, but still you should handle that situation too. In other emails I have seen a shortcode for the first name. Overall a big mess of bugs in the emails.

  • Nastia

    Hello todor , hope you're doing well!

    I can replicate on my installation that the LOGIN_ADDRESS and the WEBSITE_ADDRESS are not correct and I've reported this to our developers.

    But I can't replicate the same with the space before comma; it looks like the STUDENT_FIRST_NAME and the STUDENT_LAST_NAME values weren't inserted upon the user registration, and this is why the space showing up there.

    If you wish not to show these values, navigate to CoursePress > Settings > E-mail Settings, and edit the User Registration E-mail.

    Let me know if you have any further questions!

    Kind regards,

  • Sajid

    Hello todor,
    Hope you are doing good today :slight_smile:

    Yeap, it sounds like Nastia used a profile with empty First Name and Last Name profile fields.

    I like the idea of fall back support of using username for First Name or Last name but this will make it duplicate or triplicate. For example, if First Name and Last Name both are empty then it will display username twice like below.

    First Name Last Name = username username

    So the best way will be encouraging your students to complete their profile, specially first and last names. Or alternatively, you may need to remove these tags from email as mentioned by Nastia above.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support