Upfront Builder is giving WSOD

I'm having some issues with Upfront. After updating, I'm getting a white screen when I go to modify a theme that was created using the builder.

WordPress is at version 4.8, and Upfront and the builder are at the latest versions.

I've tried with all plugins disabled, and replaced all core files of WordPress. I've also tried rolling back to older versions of Upfront and the Builder. Nothing seems to make a difference.

Any help would be appreciated.

  • Abdul Wajed
    • Staff

    Hi Mike,

    I have checked your site tried few way to fix it but doesn't work. I'm pinging one of our SLS (Second Level Support) guys as this one is little complex and will need advanced investigation. I believe, he will come up with his valuable feedback very soon.

    Please keep in mind, our SLS people work round the clock and they have to deal with lots of critical issues and other things. So it may take a little while for them to check this and provide a feedback. I appreciate your patience.

    Have a nice day. Cheers!
    Wajed

    • Mike
      • WPMU DEV Initiate

      Hi Predrag Dubajic,

      I've updated the theme and builder to the latest versions. Same issue my end I'm afraid. I've tried the following:

      1) Disabling all plugins except Upfront Builder
      2) Switching to Fixer theme
      3) Clearing Upfront cache and browser cache

      Still getting WSOD on /create_new/{theme}

      Any further ideas?

      Cheers,
      Mike

  • Ivan
    • Developer

    Hi everyone,

    We had some major changes about how Builder is loaded in browser, meaning JavaScript has to be loaded from server, not from cache. Things to check:
    * any caching plugin,
    * WP Admin -> Upfront -> General -> Debug options -> empty upfront cache
    * be sure to reset browser cache properly

    Does browser console shows any JavaScript errors? In Chrome it can be opened with F12

    • Mike
      • WPMU DEV Initiate

      Hi Ivan,

      I'm not running any caching plugins have emptied upfront cache multiple times and have reset browser cache and DNS cache, hard refreshed, tried two different browsers and tried it on two domains, one was the fresh install. Nothing showing in the console for me in Firefox or Chrome

      Is there something I'm missing?

      • Ivan
        • Developer

        I have checked you installation, Rocket loader from CloudFlare kills Upfront. You can whitelist Upfront scripts to not be compressed by Rocket and that should resolve your issue.

        If you need further assistance about that support team will help you :slight_smile:

        • rob
          • Design Lord, Child of Thor

          I have cleared my cache, updating everything via the hub, rebooted chrome and I am still getting this error message in console:

          Uncaught ReferenceError: upfrontrjs is not defined
          at HTMLDocument.<anonymous> (secgo:319)
          at HTMLDocument.dispatch (jquery.js:3)
          at HTMLDocument.r.handle (jquery.js:3)
          at Object.trigger (jquery.js:3)
          at Object.a.event.trigger (jquery-migrate.min.js:2)
          at HTMLDocument.<anonymous> (jquery.js:3)
          at Function.each (jquery.js:2)
          at a.fn.init.each (jquery.js:2)
          at a.fn.init.trigger (jquery.js:3)
          at N.n.boot (main.js:118)

          • Adam Czajczyk
            • Support Gorilla

            Hello Rob,

            Please access your server's cPanel and see if you got any settings available for "mod_security" module there for the domain where the Upfront Builder is used. If there's such a setting and it's enabled, disabled it then again clear all caches and give it another try.

            if there's no such setting, please get in touch with your host and ask them if there's "mod_security" module enabled for the domain and if so, if they could disable it.

            If that doesn't solve the issue, we'll need to access your site directly so let me know please and if necessary I'll let you know about the secure way of providing access credentials.

            Kind regards,
            Adam

          • Adam Czajczyk
            • Support Gorilla

            Hello Rob,

            I'm pretty sure that my colleague had the "mod_security" module in mind, disabling it. I apologize for causing confusion.

            That being said, the issue seems to be resolved for the original poster and this is different due to the server that you are using. I have created a separte support ticket for you here:

            https://premium.wpmudev.org/forums/topic/upfront-builder-wsod-on-wamp

            Let's please move on to that new thread and continue there and I"m closing this thread.

            Kind regards,
            Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.