Bulk Smush problems/freezing?

Bulk Smush problems/freezing? Stops at a certain image for e.g 501/19878 and it shows it is progressing but there is no physical change in the image number stays at 501 like it isnt working through them.

Manually performing the update works no issues every image is processed every 10 seconds or less

  • marcus

    Yes as we have over 19,000 images we are working out that it was infact requiring a restart but after that it was super slow to process through.. I would imaging 40 seconds before it moved onto the next image.

    I had uninstalled the plugin and reinstalled the plugin and let it run overnight. We have woke up this morning to see this in the error log:
    "No file content sent.
    No file content sent.
    Error posting to API: 500 Internal Server Error
    No file content sent.
    Error posting to API: 500 Internal Server Error
    Error posting to API: 500 Internal Server Error
    Smush request timed out, You can try setting a higher value for WP_SMUSH_API_TIMEOUT.
    No file content sent.
    No file content sent.
    Error posting to API: 500 Internal Server Error
    Error posting to API: 500 Internal Server Error
    Error posting to API: 500 Internal Server Error"

    It is still processing through and it had done 2,000 over a 15 hour period.

    Can you also please confirm something for me.. since starting the smushing tool our server resources have grown by about 600mb in size and is continuing to grow. Is there any reason for it to grow while being smushed? We have set these options before beginning the smushing.

    Resize original images
    Include my original full-size images

    Thank you for this... we have also upgrading the the Pro version hoping to increase the speed of the smushing.

  • Denitsa

    Hey there marcus,
    I hope you're doing well!

    Error posting to API: 500 Internal Server Error

    That one's usually caused by some memory limit issues. Could you add following line to the "wp-config.php" file of your site:

    define('WP_MEMORY_LIMIT','512M');

    The line should be placed above the "/* That's all, stop editing! */" line and will increase the amount of memory available for WordPress.

    Smush request timed out, You can try setting a higher value for
    WP_SMUSH_API_TIMEOUT

    That one's a Time Out error probably. It could be happening because the size of some images is too big and they require more than 90 seconds to upload to our servers.You can increase the time limit by adding following code in functions.php file of your child theme or use it as mu-plugin:

    add_filter('WP_SMUSH_API_TIMEOUT',  'wpmu_api_timeout');
    function wpmu_api_timeout() {
     return 300;
    }

    This should increase the upload execution time value to 300 sec..

    Since starting the smushing tool our server resources have grown by about 600mb in size and is continuing to grow. Is there any reason for it to grow while being smushed?

    WP Smush Pro plugin sends the images to our servers where the optimization process takes place and then fetches them back to your website. This procedure will actually depend on your server's resources (such as connection speed and available bandwidth, available memory and PHP settings) and available resources of our servers too.
    Otherwise, the plugin shouldn't take any server resources when you're not using it (that is, when you're not not bulk smushing or uploading images and using "Smush images on upload"). When you stop the smushing altogether does it continue to grow?

    It's strange you're getting all those errors at once.
    Would you mind allowing support access to site where this is still not working so we can have a closer look at this?
    To enable support access you go to WPMU DEV > Support > Grant Support Access. You could follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Sorry for the inconvenience you are having!

    All the best,
    Denitsa

  • Denitsa

    Hello marcus,
    Thanks for all the updates here!

    I see you have deleted the WP Smush plugin altogether. Is it still OK for me to try and test it on your website?

    Could you also perhaps run a plugin/theme conflict test after you install it as described by the flowchart here:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    You could also re-login to the WPMU DEV Dashboard (after having Smush installed again) via:
    WPMU DEV -> Manage -> Edit beside the API key. That will prompt you to login again with your wpmu credentials. See how Smush behaves after that.

    Keep us posted on the results!
    All the best,
    Denitsa

  • marcus

    Very sorry yes I uninstalled and tested again once installed I did not realize I had to authorize permission again.. I would like for someone to log in and perform the task & see the problem if it can be replicated even just performing the bulk smush we dont see any progress even after 10 minutes of waiting but when we perform them manually we can do about 20 in 10 minutes.

    Thank you and please log in when you can

    Edit: Also the size issue I noticed may actually be from our caching plugin... not your application :slight_smile:

  • marcus

    Just for the record for when you log in - I had noticed the smushing stopped with no errors present so I selected cancel & logged out then closed browser.

    Logged back in and started the smush again and it has currently been on this screen below for the past 45 minutes without progression :slight_frown: please help before the trial is over as I would not like to be charged for a plugin which hasnt been working to its best potential!

  • Denitsa

    Hello marcus,
    I hope you're well!

    In order for me to log in to your website and take a look around, you'd need to grant support access again, because you relogged into the WPMU DEV Dashboard.

    Just to remind you, this is done by going to Dashboard - WPMU DEV -> Support -> Support Access -> Grant Access by following this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    I look forward to resolving this issue as soon as possible!

    Have a nice day!
    Regards,
    Denitsa

  • Denitsa

    Hey there marcus,
    I hope you're having a fantastic day!

    I just went ahead and accessed your website, when disabling all the plugins seems like the bulk smush is working properly. So could you perform a plugin conflict test as described here:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    You basically deactivate all the plugins and then start checking the Bulk smush again while activating them one by one. When you notice the bulk smush is stuck again after activating one of the plugins then that's your culprit.

    I also noticed your admin panel is kinda slow. So could you perhaps get any information about it from your host? Please update us here with what they're saying about this.

    Keep us posted on the results!
    All the best,
    Denitsa

  • marcus

    Thanks for the insight! I had logged into the panel and noticed there was a very large amount of latency in the backend too - I deactivated all plugins and the speed of the panel was dramatically faster.

    I have now performed re-activation of the plugins and can't seem to see the Bulk Smush stopping at this stage which is good I will continue to check over the next few days how the smushing goes & hope that the problem is resolved now.

  • Denitsa

    Hello marcus,
    I hope you're doing great and thanks for all the updates on this one!

    So, when deactivating the plugins and activating them one by one did you notice when exactly does Bulk Smush start to fail? I know it's kind of tedious but It's very important to test it between the activation of plugins one by one, this way we could isolate the exact plugin that's causing issues.

    Let me know how it goes!
    All the best,
    Denitsa

  • marcus

    It wasnt so much a plugin causing the crash it was when the browser/tab was closed and or the stop smushing was chosen.

    This is where the problem was replicateable and the smushing would not restart from being cancelled.

    I did not have any cancellations when reactivating all plugins so would not be able to identify what was actually the problem of the bulk smushing to not begin where it left off from.

  • Denitsa

    Hey there marcus,
    I hope you're doing well!

    What I'm seeing here is that your site speed is definitely on the low side and that's interfering with WP Smush - the plugin's working, it's just very slow. You'll have to contact your hosting provider about that.

    You should also reactivate your Jetpack plugin since it requires authentication,
    it was deactivated while testing.

    Looking forward to hearing back from you!
    Cheers,
    Denitsa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.