Bulk Smush times

Bulk Smush times out at 46%. The last bulk smush process has stuck at 0.2%

  • Nastia
    • Support Rock Star

    Hello Purrington

    Hope all is well!

    I could not reproduce the issue on your site. Bulk Smush has not stuck on my end and it has optimized 65% of all images. However, to increase the plugin's timeout, please try out the attached plugin.

    To install this plugin, please go to the back end of your site, open Plugins > Add New > Upload Plugin. Please activate it after installation and try to optimize images. The plugin contains the following code:

    add_filter('WP_SMUSH_API_TIMEOUT',  'wpmu_api_timeout');
    function wpmu_api_timeout() {
     return 500;
    }

    If the plugin will not work, please contact the WordPress.com team so they could add the following line in the wp-config.php file

    add_filter('WP_SMUSH_API_TIMEOUT',  500 );

    Hope this helps!

    Cheers,
    Nastia

  • Purrington
    • New Recruit

    Prior to installing the plugin you have provided above I was able to Smush all 28,659.

    Then I subsequently received your Smush-Timeout plugin and installed it per your instruction.

    Then I "Re-Checked" my images and as a result I was informed that I need to re-compress all 28,659 images yet again

    Should this be the case?

    The last recompression took over 36 consecutive hours to compress all the images.

    Thank you

  • Nastia
    • Support Rock Star

    Hello Purrington

    Hope you're doing well!

    Please let us know, have you done any changes in the Smush settings? Even by selecting one single option, like "Super Smush" the Smush plugin will re-check images and will show a number of images that need to be optimised, that have not been supers smushed yet.

    Please advise,

    Kind regards,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.