Bulk WP Smush is not working / progressing

Bulk WP Smush is not working / progressing. It's very slow, while my home network is 500Mbps.

  • Adam Czajczyk
    • Support Gorilla

    Hello Gabriel,

    I hope you're well today and thank you for your question!

    The performance of WP Smush Pro depends on a few different things. The 500MBbp connection is quite fast but still it doesn't mean that it's running on full speed all the time and the upload link speed is also important here (usually its significantly slower). There's also a matter of all the servers/connections "on the way" and current load of our servers. The latter one is not constant as well.

    Still, I wouldn't say that this is the most important factor here. Is there many images on your site? Are they rather huge? Please advice!

    I'd also like to take a closer look at your setup if you don't mind that. You may grant me a support access to your site following this guide here:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Gabriel,

    Thanks for granting access!

    I checked your site and the admin dashboard loads pretty slow for me in general. I checked your WP and PHP settings and I'd recommend starting with some basic tweaks:

    1. Increase PHP execution time; I assume you do have access to PHP configuration so the suggested value would be

    max_execution_time 300

    2. Increase allowed "post" data size; with current value WP Smush Pro may need to push huge images "in chunks" and this would significantly slow it down; suggested PHP setting would be

    post_max_size 64M

    3. Allow WP use entire available PHP memory; currently WP is allowed to consume up to 40M while PHP allows up to 256M; to change it please add following line to your site's "wp-config.php" file:

    define('WP_MEMORY_LIMIT', '256M');

    Could you please implement all these tweaks and then clear all site caches and let me know if it helped?

    Best regards,
    Adam

  • Gabriel
    • New Recruit

    Happy to do this changes, but could you be more specific?

    What's the file name and directory location of the PHP configuration file where I need to add

    max_execution_time 300
    post_max_size 64M

    And are those the exact lines of code that I need to add/change in the PHP configuration files?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.