Cache-Control:no-cache headers being generated

I am trying to set up fastcgi_cache in Nginx for WordPress MultiSite but wordpress is always generating this header:

Cache-Control:no-cache

This is making Nginx to not cache any wordpress pages. I have disabled all plugins and WordPress still generates this header.

Anyone know what is going on?