Caching and WPML not working well.

On my site, I'm using the WPML translation plugin. My theme has an Ajax feature that after clicking on action button more posts are loading.
When selecting the second language (French) with Page Cache enabled, in Hummingbird, this feature loads post in English. With Cache deactivated, the posts are loading in French as they should be.

  • Nithin

    Hi Jacques David Commarmond,

    When selecting the second language (French) with Page Cache enabled, in Hummingbird, this feature loads post in English. With Cache deactivated, the posts are loading in French as they should be.

    I could notice the issue. But, I'm afraid, I'm not able to replicate the issue specifically with Hummingbird Page cache.

    The page works fine when logged in with Hummingbird Cache enabled, or disable. When logged out the issue still occurs irrespective of the Hummingbird Pro cache.

    I could notice the issue still exists in your staging site even with Hummingbird Page cache disabled, I also tried deactivating Hummingbird Pro plugin as a whole, and could still notice the mentioned section appears in English after "PLUS DE POSTS" button is clicked. It works fine only when logged in.

    This seems more like the theme compatibility issue, are there any cache settings is the theme side? I have currently disabled Hummingbird plugin in your system, could you please check, and see whether you could replicate the issue when logged out?

    Please do advise if I'm missing anything specific so that we could help get you sorted asap. Have a good day ahead. :slight_smile:

    Regards,
    Nithin

  • Nithin

    Hi Jacques David Commarmond,

    The issue only occurs when logged out, the posts do translate when logged in even when Hummingbird Cache was activated. I'm afraid, this is still an issue with cache or theme incompatibility.

    If it was related to the Hummingbird Pro plugin, deactivating the Hummingbird Pro plugin should have worked. It seems like the tests done was when logged in, during live chat, and hence it gave an impression it worked when Hummingbird was disabled.

    It seems like the login credentials shared for the testing site is no longer working, so I couldn't check it further. Was getting the following message:
    ERROR: The password you entered for the email address pencixxxxxx@gmail.com is incorrect. Lost your password?

    Could you please deactivate all the plugins except WPML, and check whether you still notice the same issue when logged out? It should translate, and work fine when logged in.

    In general, page cache doesn't get enabled when logged in, and it only caches a page when logged out. So, chances of such anomalies do relate more regarding the cache.

    Would also recommend checking with WPML support to ensure whether they are aware of such issues, and have any workarounds or not too:
    https://wpml.org/forums/forum/english-support/

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.