Caching causing issues with Market Press cart pages

I have been using WP Super Cache on my Wordpress site. We recently put up a small MarketPress shop. I've been having issues with cart pages not refreshing, refreshing and giving users a "no items in cart" message. Needless to say, my users are frustrated. I've done a lot of plugin disabling trying to figure it out, and it has come down to me having to disable WP Super Cache in order to appease users. I understand (or think I do anyway) thru some research here that this is because of full page caching. I've read a lot of the posts and have pretty much figured out that I need to disable that. My cart appears in the sidebar of (nearly) every page on my site. I am at a loss on how to proceed. Obviously, I do not want to keep caching turned off. Next thing is, users will be complaining about page load speed. I'd love some specific help on how to remedy the conflict with WP Super Cache and Market Press or... suggestions for a different cache that plays nicely.

  • Michael Bissett
    • Recruit

    Hey @jan, Michael here! :slight_smile:

    If you're still wanting to use WP Super Cache, you could go to:

    Settings -> WP Super Cache -> Advanced

    And inside the section that starts out with "Add here strings (not a filename) that forces a page not to be cached.", you could add this to the list of items there:


    Otherwise, if you'd like to try using the W3 Total Cache plugin instead, you'd want to go here:

    Performance -> Page Cache -> Advanced

    And add these two cookies to the "Rejected cookies:" section


    Another note regarding WP Super Cache (if you still plan to use it): Please be sure that inside of:

    Settings -> WP Super Cache -> Advanced

    That the rewrite rules are not needing an update already, and if they are, please be sure to update them.

    Hope this helps! :slight_smile:

    Kind Regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.