Caching error

Hi,

I'm trying to improve my page caching times and keep getting the following error : "Hummingbird detected an advanced-cache.php file in wp-content directory. Please disable any other caching plugins on order to use Page Caching." I have removed all other caching programs and connected with cloudflare. Where do I go from here? Thanks!

  • Dimitris
    • Support Star

    Hello there Heather,

    hope you’re doing good today! :slight_smile:

    wp-content/advanced-cache.php isn’t used by HummingBird but by other caching plugins like W3 Total Cache.

    It seems that deactivating and deleting these plugins, don’t remove the file itself though, so could you please try to access your server via FTP (or from any other File Manager program, or via your server panel), remove this file and check again?

    Warm regards,

    Dimitris

  • Dimitris
    • Support Star

    Hey there Heather,

    hope you’re doing good today! :slight_smile:

    I don’t think that these notifications are getting cached… In order to better troubleshoot this, could you please share some server credentials? As this is public forum, you should send us your details through our safe contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: “Attn: Dimitris

    – WordPress admin (login url/username/password)

    – FTP credentials (host/username/password)

    – cPanel/Plesk credentials (host/username/password)

    – link back to this thread for reference

    – any other relevant urls

    Keep in mind the subject line as ensures that it gets assigned to me.

    Warm regards,

    Dimitris

  • Dimitris
    • Support Star

    Hey there Heather,

    hope you're doing good today and appreciate the contact details that you've sent! :slight_smile:

    I just went ahead in wp-admin area and couldn't locate this error message though.

    Is this resolved by now? Or am I missing something here? Please advise!

    Warm regards,

    Dimitris

  • Heather
    • New Recruit

    Yes, it seems like the caching error is gone after deleting the file you recommended. However, my “remove render blocking resources” score has dropped from 50 or 60 to 31. Since that was the only change I made, I thought maybe it was related. If not, do you have any idea how that score would decrease?

  • Dimitris
    • Support Star

    Hello there Heather,

    hope you’re doing good today and I’m glad you’ve managed to resolve the caching error! :slight_smile:

    Changes in this score, can be happened only if you’ve made some changes in your themes/plugins, so different JS and CSS files are getting loaded.

    As for the “remove render blocking resources” case, please have a read at the following article from our blog: https://premium.wpmudev.org/blog/eliminate-render-blocking-issues-hummingbird/

    What you should experiment with, is moving assets to footer so they load after the above-the-fold content. For doing do, you can use Asset Minification in advanced mode and play with the footer, inline and defer options.

    More detailed usage information can be found in our doc page here:

    https://premium.wpmudev.org/docs/wpmu-dev-plugins/hummingbird/#chapter-4

    Keep in mind that there are many cases, where it’s impossible to move all reported files to footer, as this may break your frontend pages. Despite that, you should try to remove as many as possible, in order to get the best possible score.

    If this still troubles you, and as we’re keen on having separate threads per issue, please do reach us here https://premium.wpmudev.org/hub/support/#get-support for a live chat session or in order to create a new thread in our support forums.

    Warm regards,

    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.