Calendar Pulling appointments incorrect (IMPORTANT)

Need help quickly please.

My calendar is pulling my appointments from my calendar, but setting them on the appointments calendar 1 hour earlier than their scheduled for. ALSO it's not pulling all the information. There's random sessions such as this saturday at 11am. Its been on the calendar for several days but hasnt shown up in Appointments.

  • Luís

    Hi @mike316,

    Hope you're doing well today!

    I tried to access your site using support staff access, but it's displaying the following error message:

    Sorry, this is an invalid access token. You must ask the user to grant access.

    Could you please revoke and after regrant the support staff access again?

    However, your system shows you are using a old version of Appointments+ (1.7).

    Can you upgrade to the new version (1.7.1)?

    Cheers, Luís

  • Luís

    Hi @mike316,

    Hope you're doing well today!

    Firstly, sorry for my late reply and all the problems it may have caused.

    The update corrupts my site. See attached.

    This bug was already reported, the developers are aware and working to fix it asap. You have the WP_DEBUG flag enable in your wp-config.php? If, yes, can you disable it and try again the plugin.

    Regarding to the calendar issue, you are using the same timezone (in your google calendar and WordPress settings?)

    It was reported a bug regarding to the Google Calendar import feature (Appointments+ Version: 1.7.1) . When we import an appointment from Google Calendar they appear in the Appointments+ set for today, for midnight. We need to import it again to show the correct date and time.

    But regarding to your version (Appointments+ Version: 1.7) I was unable to replicate.

    Google Calendar Settings have changed on version 1.7. If you have been using Google Calendar prior to 1.7 you will need to review your settings. I think the best option is reset your API credentials and "Create a new Google Application" as described in Appointments -> Settings -> Google Calendar.

    Cheers, Luís

  • Mike

    So I did the API over again following step by step which were accurate and put in the new credentials. Now i get this (see attached 1)

    When i click on generate your access code, i get a 404 page.

    401. That’s an error.

    Error: invalid_client

    My calendar is the right timezone, the Appointments + is the right time zone, and my Wordpress is the right time zone. Not only is the calendar putting appoitnments in the wrong time slot (hour behind) it's not even pulling all of the appointments. Such as Wed, 3/30/2016, its showing i have 1 session at 6am when i have (on my Google Cal) appointments at 11am, 12pm, 7pm.

    You had access to my account and my website. Was anything done incorrectly?

    The OAuth client was not found.

  • Mike

    I NEED THIS FIXED! THIS HAS BEEN BROKEN FOR WEEKS NOW WITH NO HELP. IVE GIVE SUPPORT ACCESS SEVERAL TIMES AND I KEEP GETTING NO WHERE.

    Ive tried everything that you've listed. The plugin is updated. Its not setting the schedule properly even remotely close. Its not pulling all the appointments and the ones it does, it's putting them in the wrong time slot.

    What do i have to do to get this fixed?! Ive paid for the plugin and almost bought the year subscription, but this service has been terrible so far its making me glad i havent.

    Can someone help me or refund me? If it doesn't function properly, it shouldnt be sold.

  • Luís

    Hi @mike316,

    Hope you're doing well today!

    Firstly, sorry for my late reply and all the problems it may have caused.

    Can you give us FTP access to your website, so we can try track the origin of the issue. Can I use my google account to test your website?

    Please send it privately through our contact form:

    https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Luis Lopes"
    - WordPress admin username
    - WordPress admin password
    - Login url
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant urls

    Cheers, Luís

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.