Can I have a different site at the bare domain of my multi-domain?

Hi all
I have a network at domain.com and have successfully configured domain2.com as a second domain.
I would like to have a separate site at domain2.com, currently that redirects to domain.com.
Is that possible?

[I am able to create a site, and map "www.domain2.com" to that site; but no the bare domain - I could live with that if I need to]

  • John
    • Design Lord, Child of Thor

    Hi Ari, I can confirm I set the domain name in multi-domains without the www.

    When I said I could create a site, and map "www.domain2.com" to that site, I meant that I created a site whatever.domain.com and mapped "www.domain2.com" to whatever.domain.com.

    All my domain mapping and multi domain setup works fine. I only want to know how I can map a bare domain to the same bare domain that is used as a additional multi domain, instead of all the bare domains of the additional multi domains redirecting to the bare domain name of the main network installation.

  • aristath
    • Recruit

    I'm afraid that at this point I 'll have to see it myself and try to figure out what is happening.

    Could you please email me your superadmin creadentials?

    Send an email to aristath at incsub dot com
    - Include you superadmin username & password
    - Include a link to this thread so that I can better track this issue.

    Cheers,
    Ari.

  • John
    • Design Lord, Child of Thor

    Hi Ari
    Nothing unexpected is happening, as I said, the plugin and my setup work fine and as expected and intended by the developer.
    It is normal behaviour for all bare multi-domains to re-direct to the main domain.
    What I am asking is whether there is a A or a CNAME record I can create which will allow me to create a different site and re-direct the bare multi-domain to that site, without changing anything to the current setup.

  • aristath
    • Recruit

    Oh, sorry, I must have misunderstood your previous posts.

    This can be done using the domain-mapping in combination with the Multi-Domains that you're already using.

    If you already are using it, please make sure that you have the correct sunrise.php file as when these plugins are used together a different sunrise file is required. Rename dm_sunrise.php to sunrise.php and upload it to the /wp-content folder on your site.

    After you set these 2 up you'll be good to go. :slight_smile:

    I hope that helps!

    Cheers,
    Ari.

  • aristath
    • Recruit

    Hiya, just going through some of the older threads here.

    As it's been a little while since we last heard from you I thought I'd check in to see how you're going?

    If you're still looking for some further assistance with this thread then please feel free to reopen the thread or of course for any new and related issues you are most welcome to open a new thread.

    Thanks.
    Ari.

  • aristath
    • Recruit

    When I visited your site, I went to the Network Admin => Settings => Domain Mapping
    There is the following notice there:

    You may have some lines in your wp-config.php file that will interfere with the operation of the domain mapping plugin, can you please check and remove the following lines:.

    define( 'DOMAIN_CURRENT_SITE', 'hinterlandsites.com.au' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    Could you please try doing as advised by this notice and let me know if that works?
    Cheers,
    Ari.

  • aristath
    • Recruit

    If you want a domain you have used in the multi-domains plugin to stop redirecting to the main site, you'll have to create a new site and using the domain-mapping plugin assign the domain to it. If there is no site with that domain assigned, then it falls back to the main site.

    In your email you also asked me why the domain using www. is not going anywhere...
    It works fine for me and it redirects to the domain without the www.
    Have you added wildcard dns in your DNS entries? (from your hosting panel or your domain registar).
    If you have and you still can't get it to work, you'll have to add some lines to your .htaccess file, see this thread for more info: http://stackoverflow.com/questions/234723/generic-htaccess-redirect-www-to-non-www

    I hope that helps!

    Cheers,
    Ari.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.