Can I have multiple schedules in Appointments+ to allow for different schedules for different depart

Is there a way to have multiple schedules that accept appointments?

I would like the Detailing Department to have a separate schedule from the Service Department, for example.

Looking forward to hearing back, and thanks for your time, help and attention.

Best,
Curt

  • Curt
    • New Recruit

    Hey Tom,

    Thanks for the reply - that's an excellent idea.

    By breaking the Departments into Service Providers and ensuring that I add worker="ID" to the services and monthly schedule shortcode, I have made it such that each department can have it's own schedule.

    However, I seem to have created an issue with the times available to book appointments.

    I had played around with the time base yesterday, realizing that if I did 30 minutes instead of 60, customers could select an appointment to start at 0830, 0900, 0930, etc.

    Since I made the change (and updated to v1.3), the schedule only allows customers to choose a time slot equivalent to how long the service would take, were it to be done one after another, starting at the beginning of the day.

    For example, a "Bronze Detailing" takes 120 minutes. Hours are 0800-1800.

    I should be able to book an appointment at 0800,0830,0900,0930, etc..

    However, it is only showing the possibility of booking at 0800,1000,1200,1400 and 1600.

    If someone booked an appointment at 0800, it would make sense that another wouldn't be available until 1000, but just as valid would be to book an appointment at 0930 and then not be able to book another until 1130.

    There are no breaks set, working hours look to be fine, time base is set to 30. Not sure why it isn't showing all available times.

    Any ideas on this?

    Thanks again

  • Curt
    • New Recruit

    Hey Tom -

    Those seem to be OK. 30 minutes is fine for a time base for what I'm after. The Admin-side flexibility will help, but still does not allow people on the front-end to choose anything but 8, 10, 12, etc. (see screenshot of front-end)

    Thanks and best,

    Curt

  • pxwm
    • WP Core Meltdown

    Hi @Tom Eagles - Hope you don't mind me chiming in

    Hi @Curt

    Is it possible you could screenpost the following:-

    All the settings for the 'General' tab

    'Working Hours' tab for:-

    the 'no specific provider'
    and for each service provider

    Regards
    SteveB

  • Curt
    • New Recruit

    Howdy - thanks very much for taking the time to help.

    I've attached screens of the General tab and the Working hours tabs. There's an additional screen that I will post momentarily.

    Thanks again and best,

    Curt

  • pxwm
    • WP Core Meltdown

    Hi @Curt

    I've checked your settings and they all look fine except for the 'Working Hours'

    Could you please try the following to see if this fixes your problem:-

    Login to A+ Settings
    Then 'Working Hours' tab
    Then select 'no specific provider' and set all days to 'NO'
    Then save

    This will 'Block' the available time for a 'no specific provider' so the user will have to select a specific service provider to view there available time in the scheduler.

    Please let me know if this works.

    Regards
    SteveB

  • Curt
    • New Recruit

    Hi Steve,

    Thanks for the suggestion. I just turned all days to NO, yet the problem persists. The front end still only allows for an appointment to be booked at 0800, 1000, 1200, etc.

    Thanks for your continued support, it's much appreciated.

    Best,
    Curt

  • pxwm
    • WP Core Meltdown

    Hi @Curt

    I think I've identified your problem.

    Could you try the following:-

    Login to A+ Settings
    Then Select the 'General' tab
    Then change the value of the 'Appointments lower limit (hours)' field from '1' to '0' (default)

    I'm hoping this resolves your problem as I think setting the limit to 1 hour is limiting the next time an appointment can be made.

    Please let me know if this works

    Regards
    SteveB

  • Curt
    • New Recruit

    Hey Steve - unfortunately it is still not showing the half hour blocks I desire.

    It's strange, but when I had only set up one service provider (before the update, in case that has anything to do with it?), I got it to display time slots in 30 minute intervals simply by changing the Time Base to 30 from the default 60.

    Best,

    Curt

  • pxwm
    • WP Core Meltdown

    Hi Curt,

    Could you please confirm how many appointment pages you have?

    Could you provide a list of shortcodes you have in each appointment page

    Would you mind providing a screenpost of the latest settings in your 'General' tab.
    I only need to view the 'Time Settings' section at the top of the page.

    Regards
    SteveB

  • Curt
    • New Recruit

    Hey Steve -

    I have 2 appointment pages: Detailing and Service.

    Detailing shows only those services provided by Detailing (there are 4 services, ranging from 2 hours to 6.5 hours). Service shows only those services provided by Services (there are 14 services ranging from 60 minutes to 4 hours).

    Detailing Shortcodes:

    [app_services select="Please select a package" description="none" autorefresh="1" worker="3"]

    [app_monthly_schedule logged="Click on a free day to book your experience." worker="3"]

    [app_pagination month="1"]

    [app_confirmation confirm_text="We have scheduled your appointment. Thank you! You will receive reminder emails 24 hours and 1 hour in advance of your appointment.]

    Services Shortcode:

    [app_services select="Please select a package" description="none" autorefresh="1" worker="2"]

    [app_monthly_schedule worker="2" logged="Click on a free day to book your experience."]

    [app_pagination month="1"]

    [app_confirmation confirm_text="We have scheduled your appointment. Thank you! You will receive reminder emails 24 hours and 1 hour in advance of your appointment.]

    Screen of General is attached.

    Thanks again for all your help.

    Best
    Curt

  • pxwm
    • WP Core Meltdown

    Hi Curt

    I've carried further testing and it looks as though there may be a bug in v1.3 where the duration of the Service is overriding the Time Base settings in the 'General' tab.

    Hi @Tom Eagles - Is it possible you could flag to Vladislav so he could test and confirm?

    Regards
    SteveB

  • ndnault21889
    • New Recruit

    Thanks for flagging me on this in my other post @pxwm. I can confirm that I've got the same issue. Prior to the update, available times showed based on what was set in the time base (ie. 30 min time base gave appt choices on the half hour). Since the update, that has changed and I'm seeing the exact problem as Curt has referenced above.

    As this is impacting a client's business in real time, a quick fix or the ability to roll back to the previous version would be appreciated.

    Thanks.

  • Curt
    • New Recruit

    Thanks @ndnault21889, good idea on the roll back to the previous version. I'll have to do that if we can't get a solution here in the next couple of days - glad we could connect on this issue.

    @pxwm, thanks again for your help, you've gone above and beyond.

    @Tom Eagles Thanks for looking into this, appreciate your support. Will wait to hear back.

  • pxwm
    • WP Core Meltdown

    Hi @Curt and @ndnault21889

    Glad I could be of help.

    Just one warning about rollback.

    The rollback will be fine if you took a backup of the database before you upgraded and/or you didn't make any changes to settings that have just been introduced in v1.3.

    e.g. There are changes to v1.3 in respect to additional breaktimes and this is not supported rolling back.

    So just be careful if you rollback and you didn't take a backup of the database before you upgraded.

    I always suggest as a minimum you take a backup of your database and home directory before upgrading any plug-ins and Wordpress.

    Regards
    SteveB

  • Curt
    • New Recruit

    @Tom Eagles @pxwm

    Hey Steve -

    I haven't heard anything, yet

    This site doesn't get launched for another few days, so I am hoping I won't need to go back to the previous version. Was holding off as long as possible in case we get a fix.

    Thanks for your continued help. Hope to hear from somebody on a fix for this.

    Best,

    Curt

  • Vladislav
    • Dead Eye Dev

    Hello,

    The services duration calculus has been changed somewhat in the last release, to reflect service durations rather then the pre-recorded intervals, so this is in fact not a bug - by default, the duration calculus is now service duration-based. The next release will, however, have an option of reverting back to the old, minimum time based slot duration calculus. In fact, if you're interested in taking it for a spin, I have responded a few days back to the other thread mentioned here with a Beta that offers this option: https://premium.wpmudev.org/forums/topic/having-difficulty-setting-up-appointments#post-473538

  • Vladislav
    • Dead Eye Dev

    Hello,

    Just to update the thread with info for the latest plugin release (v1.3.1, just released). In addition to the APP_USE_LEGACY_DURATION_CALCULUS define (which will still work, as in the Beta version attached in the other thread), the release also comes with an add-on named "Durations". Activating this add-on will add a new option in your Settings > General > Time Settings area, named "Time slot calculus method". Using this new setting, you can easily toggle between duration calculus methods without leaving the admin UI.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.