Can I make my site compatible with Internet Explorer 8?

A member wrote to enquire why the site is not compatible with IE 8. I have just tested it and get the following: "Internet Explorer has stopped working".

  • Alexander

    Hi @PCI Team,

    I apologize for the delay here. Thanks for the extra info. I've been able to confirm with a colleague that this happens on IE8.

    I've done some research, and this is an unfortunate bug in IE8 caused by certain ways javascript can be used. It's likely that a plugin or your theme is causing this issue by using javascript functionality that works in modern browsers, but IE8 doesn't support, and fails to provide a graceful fallback.

    Can you please test for a plugin and theme conflict? You can do this by switching to the default theme (TwentyThirteen) and deactivating all your plugins. After this, test the issue as see if anything is different. If it's working, try changing your theme back and testing again. If at this point it's broken, we know it's a theme conflict. If not, start reactivating your plugins and testing as you go along, once it stops working you'll be able to know which plugin is causing a conflict. Once a conflict is identified, we can look into a specific solution for it.

  • PCI Team

    Hello Alexander

    Many thanks for your suggestions. We tested the site last night by changing the theme to Buddypress default and Blogs MU theme - and: it works with IE 6-8.

    It seems there is a problem within the changes that we have made to the website and integrated in the Blogs MU child theme (child theme to secure the changes in case of theme updates).

    By disactivating the Blogs MU child theme we have solved the browser incompatibility issue, but now some previously-solved problems are occurring again, eg:
    - 'Recent Blog Post' showing in footer instead of 'Sign-up to our Newsletter' form (the blog post titles include confidential information such as client names which means they are now visible to not-logged-in Visitors and logged-in Users)
    - display of categories "Archives" which means that everything in the Category is displayed rather than just the posts which are specific to the user's access level
    - coloured haze around the footer

  • PCI Team

    Hello Alexander.

    In the end, because of the confidential information showing up in the 'Recent Blog Post' on the home page, we just switched the child theme back on and have not resolved the IE8 incompatibility issue. I have now asked the person who identified that the problem was with our Blogs MU child theme whether he deactivated all plugins before switching the Blogs MU theme and then the Blogs MU child theme back on. Apparently not:

    “no I was checking the theme first - when I was switching to Blog MU theme without having the Browser issues anymore it was already clear that the problems must be in the child theme!”

    Do you think he is right or is there a possibility that there is a conflict between the child theme and a plugin, in other words is it still necessary to revert to the default theme and deactivate all plugins and reactivate one by one? And can I just check that for this discussion 'widget' and 'plugin' is the same thing?

    In case it helps, below is the list of points that were included in the child theme, step by step:

    - CSS edit on Posts to hide all the category, tag, date, and person info under a post title
    - Remove the bottom navigation on posts. When an individual post is displayed – I’d like to have the suggested post items removed from the bottom (unless there is a plugin to ensure it only shows things by category – otherwise it’s too random)
    - Remove the sub-intro post thing from homepage and above posts
    - For category pages – would like to either remove ‘Level 1 archives’ or ‘Resources archives’ heading completely. Either that or delete the word archives and only have it list the category name.
    - On the homepage you’ll see under the picture ‘Performance Improvement through Coaching and Leadership Development’. In the dashboard I’ve found that the space for that is under Appearance > Theme Options > Homepage Settings and it’s the last section titled ‘Your Network sub intro post text’ I’d like to remove that but when I leave it blank or try with spaces, it removes it for a short while but then defaults to what the template had in there about community. Just want it gone completely so there’s less white space (it also shows as a second header on all normal pages too – but the text is white so you can’t see it).
    - Remove the weird haze around the footer (like the rainbow bit at the bottom – odd!)
    - Find a way to re-format how posts that are part of a category display. I have changed settings to say ‘summary’ but it still shows quite a bit so I’d like for it to only be the title of the post and maybe 1-2 sentences.
    - Add 404.php file to the blogs.mu template so we can use a custom error page (Have already created the page, just need it connected)

  • PCI Team

    Hi Alex

    I disabled all plugins and changed to the default theme TwentyFourteen but our site is still not accessible from IE8. I have attached two screen shots with the error message in case it helps. The problem is now very serious because we might lose a major client if we cannot make our platform available to IE8 (apparently it caused their computer to crash). So you don't have to hunt through earlier messages, the web address is http://pci-learning.com. Is there anyway that someone can help look at the back end if I give them access details?

    Many thanks for anything you can do, as quickly as you can!!!

    Frances @PCI Team

  • PCI Team

    Hello again
    We cleared the cache, renamed the child theme to _blogs-mu-child and now using Blogs MU theme. This has enabled access from IE8 to our home page http://pci-learning.com and all unprotected content.
    However, as soon as you try to login from IE8 it stops working and you get the same error message as in the above two screen shots. Do you have any idea what could cause this?
    Many thanks and kind regards
    Frances @PCI Team

  • PCI Team

    Hi Alex

    I've been advised that the reason IE8 crashes when trying to login to our site is most likely to do with a cookie error. The links to two topics below seem to be most relevant to what we've been experiencing on various browsers (IE9, IE10, Chrome version 32.0.1700.76 m). We frequently fail when first logging in from http://pci-learning.com/login/ (even if we tick 'remember password') and are then directed to http://pci-learning.com/wp-login.php with the following error message:

    "ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress."

    Logging in again from the wp-login.php page is usually successful (without making any amendments to cookies settings) unless of course you're on IE8 which crashes on the first attempt.

    http://wordpress.org/support/topic/cookie-error-when-logging-in?replies=117
    and
    http://wordpress.org/support/topic/cant-log-in-to-wp-admin-after-updating-to-wordpress-38-cookies-error

    It seems that lots of people are having similar troubles and have found various ways to fix it. Please can you advise the best fix so that we don't have to try them all!

    Many thanks for your help

    Frances @PCI Team

  • PCI Team

    Hi Alex

    Thanks for your response. We only have one site and haven't installed the Domain Mapping plugin if that is what you mean. Presumably that is the reason that we can't find sunrise.php? Are you suggesting that we install the latest version of Domain Mapping and activate on our network, or did you just mean that if we had already installed it we needed to make sure it was up to date? And if we don't use domain mapping, do we need to download sunrise.php anyway? If so, where should we download it from and where should we install it?

    As you know, I submitted this query 3 months ago and we really need to find a way to allow people using IE8 to be able to log in to our site, without having to replace the Blogs MU theme. We have analysed the http traffic and it seems to be failing after it gets the File.. dashicons.min.css.. (which I guess is a css for the icons used in the page). I only see this requested when i try to login, or land on the wp-login.php page.. so presumably it's something that follows that request.

    Can the Blogs MU theme developers help or do I need to start a new thread under the topic Blogs MU?

    Thanks very much

    Frances @PCI Team

  • PCI Team

    In case anyone else suffers the same problem with Blogs MU and is reading this thread, here is how we solved it:

    After lots of time spent changing themes, removing widgets and plugins, reinstalling widgets and plugins, looking at cookies, hunting through code for errors and trying to add code to the header.php to force IE8 into IE7, we finally resolved this on Sunday. Not knowing how to do it myself, I paid someone to update modernizer.js to the latest available (2.7.1 I think) and now it works perfectly.

    I paid a professional for the following diagnosis of what was causing Internet Explorer 8 (IE8) to crash when attempting to log in to our Blogs MU themed site. This is what they found:

    - - - - -
    On every page it loads, then starts loading again, but never finishes loading. You have a script which starts running after page load and will probably cause a stack overflow if left to keep running

    Twitter widget and modernizr.
    Your version of modernizr is very old
    I can get in using compatibility mode
    - - - - -

    I removed the Twitter widget but that did not solve the problem. I could also log in by manually switching IE8 to compatibility mode (ie to behave like IE7) but was unsuccessful in trying to force IE8 to IE7 by adding code to the header.php.

    It was only once the modernizr was replaced that IE8 stopped crashing on login. I hope that this information will feed back to the Blogs MU developers.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.