Can not import member list to enewsletter

Hello, when trying to import a list of subscribers I get a notice that says "These emails are incorrect:" followed by a list of email addresses. The list of emails has been verified by a paid verification service so they should all be correct. I have attached a screenshot of the message so you can see what's happening.

  • Lindeni Mahlalela

    Hello Lou,

    I hope you are doing great today, thank you for contacting us and sorry for the issues and inconveniences you are experiencing.

    I have done a couple of tests on my side and have seen the same issue when I have a Comma separated CSV but choose Semicolon when importing. So it seems this is related to the format of the imported CSV and not whether the email accounts are invalid or not.

    I suggest you check the CSV for the correct format, if columns are separated by a comma then you must choose "Comma (,)" in the "Separated by:" option and choose "Semicolon (:wink:" if separated by a semicolon. If its not one of these then you should edit your CSV so that columns are either separated by a comma or a semicolon, sometimes a CSV can be separated by a Tab, space or another character, please check yours and make it either a semicolon or comma.

    Please find the attached sample files and try importing them as examples. You should see that if you import the 'semicolon_separated.csv' but choose or leave "Comma (,)" option selected, you will get the errors as in the screenshot.

    I hope this helps, please do not hesitate to let us know if you are having any further issues.

    Cheers,
    Mahlamusa

  • Lou

    Hello,

    Thanks for the reply. I have checked the CSV files, and they are comma separated. I am also choosing to upload a comma separated list, so I don't think that's the issue. I have uploaded lists like this in the past with no issues. I have done some testing of my own and it seems that when these files are created or edited/saved from MS excel on windows they will not upload, but if I create them using Numbers on Mac they upload just fine. I found another post here that suggests it could be the line endings used in excel, but I don't know much about excel or how the line endings can be changed.

  • Lindeni Mahlalela

    Hi Lou,

    Thank you for your detailed feedback and yes, you are right about MS Excel, that is how it behaves, to make things simple for you, you can try to open the CSV file using a Text Editor, I use Notepad++, once the CSV is open in the text editor, go to "File > Save As" and save the file as a copy from notepad. That should get rid of MS Excel's incompatible format.

    Please try that and let us know the results, we will always be happy to help in anyway possible.

    Have a nice day.

    Cheers,
    Mahlamusa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.