can not install my Pay to Blog Pugin

I just purchased the Pay to Blog Pulgin and uploaded it to my Wordpress. When I try to activate the plugin, I get this message. Plugin could not be activated because it triggered a fatal error. Web Invoice requires PHP 5.2 or better. Please upgrade or switch to a host that supports PHP 5.2 like Pacific Host.

My webhosting company is Godaddy and I checked with them to verify that I am using a PHP of 5.2 so this should not be an issue.

Does anyone know how I can fix this problem so I don't keep getting this error message when I try to activate the Pay to Blog Plugin?

Thanks
Joe
E-Mail: josephamailbox@aol.com