Can not load upfront editor in a page with google maps

Hi,
I can not load the upfront editor for the page /contact of my website.
http://new.marcelodena.com/contact/

For the rest of the pages (where there's no google map), the upfront editor loads withou any problem.

I had a similar problem with this and the solutions was to disable API Google Maps from the Ubermenu plugin:
https://premium.wpmudev.org/forums/topic/can-not-to-edit-a-page-with-upfront#post-995357

but in this case I have not installed the ubermenu plugin, so I don't know how to solve. Could you please help me ?

Thanks,
Marcel Odena

  • Predrag Dubajic
    • Support

    Hey Marcel,

    Hope you're doing well today :slight_smile:

    Are you using Google Map element available withing Upfront or you're using third-party plugin?

    If you open Upfront editor on main page for example, can you try clicking on Pages/Posts/Comments and switch to contact page from there and see if it will open it.

    If that doesn't help would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Predrag

  • Marcel Odena
    • Site Builder, Child of Zeus

    Hi Predrag,

    I'm using Google Map element available withing Upfront, and I tried also to open Upfront editor on main page and tried clicking on Pages/Posts/Comments and switch to contact page from there but it doesn't work either.

    I granted you access to the website.

    Looking for news,
    Regards,
    Marcel Odena

  • Predrag Dubajic
    • Support

    Hi Marcel,

    Thanks for granting access, I've checked your site and can see the issue on Contact page but I can't replicate this behaviour on test page I created with both Map and Contact elements added.

    Is there anything else added to that specific page that could be causing this?

    Have you tried recreating the page to see if it will happen again?

    Best regards,
    Predrag

  • Marcel Odena
    • Site Builder, Child of Zeus

    Hi Predrag,

    Yes, I tried to create a new page and the same problem happened. What I did is to add a section, and from the config options of the section I select from the drop-down menu the option "Map". I realised that I can not specify the address, so it was quite surprising. After saving the page the problem appears, then you can not edit the page with upfront, so it's like a no-way-back path.

    I repeated this actions to the page you created (/test-wpmu) and the problem occurs (you should see that now you can not load the updfront editor). So my questions are:
    1. Can I configure the map from the options of the section? Is it still supported or is it a deprecated method? Some months ago this method worked, actually this page is done with this method:
    http://magneticaadvertising.com/contactar/

    2. In case I have to do it like you did in the /test-wpmu page, how can I do in order the map expands to both edges of the page (screen)?

    I attach some screenshots where you can see the changes I did to /test-wpmu and how the problems also occurs.

    Cheers,
    Marcel Odena

  • Predrag Dubajic
    • Support

    Hi Marcel,

    Thanks for further explanation, I wasn't looking at the right thing before, sorry about that.

    I have tested this now and can see the issue myself now, developers are currently working on a new version so I swooped them this as well to have a look at it as soon as possible :slight_smile:

    2. In case I have to do it like you did in the /test-wpmu page, how can I do in order the map expands to both edges of the page (screen)?

    There's a CSS "hack" that can do this but let's see first what devs say about this before we go this other route.

    Best regards,
    Predrag

  • Marcel Odena
    • Site Builder, Child of Zeus

    Hi Predrag,

    I updated the version of Upfront. I tried to load the upfront editor to the /test-wpmu and does not load the upfront editor. You can test yourself. If you want you are allowed to upgrade the upfront version if you need, the site is not still in production.

    I attach some screenshots

    PD: is there any easy way to see the exact upfront version installed ? I updated but I don't know how to see it, upfront doesn't appear in the theme section neither in the plugins sections of the wordpress admin panel.

    Thanks,
    Marcel Odena

  • Predrag Dubajic
    • Support

    Hi Marcel,

    Looks like there's an issue on some installations, including yours unfortunately, where pages that had Map region before update are not working but good thing is that you can create new one and it will work normally, you will also see map options when you select map for region background.
    I have notified developers about this and they are looking into it.

    As for Upfront version, you will see if there any pending updates in your dashboard, if there's not you're all good :slight_smile:

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Marcel,

    I have created my own test page on your site before my previous comment to be sure it's working :slight_smile:

    You can go to your pages and delete both wpmu test and new wpmu test pages.

    Glad to hear this is sorted out now and hopefully devs will be able to figure out quickly why old pages are not still editable after update.

    Have a great weekend!

    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.