Can not local Buddypress 1.5.3.1 Language

I've tried to local buddypress by changing po file and compile it. But it seems doesn't work. The result still same before. Any one can help?