Can not login to dashboard

Hi,
I've followed the install guide...

I added Multi-Domain, added my domain name. I created the new A record.

I can visit the front end, madsen.egglestonbunch.com, but when I try to go into the dashboard, I'm redirected to the WordPress login page. I try to login, but am continually redirected to the login page. No error message, just keeps refreshing the login page.

I've tried just about everything I can think of...

Thanks
Chris

  • aecnu

    Greetings Chris :slight_smile:

    I got right on this and it works just fine on my test site.

    Since I could not find a problem with our test subject, I went ahead and researched your domain and its IP and found that it is not on a dedicated IP but shared IP with at least 10 other domains.

    IP address: 50.57.187.241

    and both the root domain and sub domain resolve to this IP.

    We ourselves setup multi-sites only on Dedicated IP's

    I am not saying this is the problem - I honestly do not know if this is the bottom line problem :-S

    The reason why I asked you about Tucson is because my nephew looks just like you but is in Tucson :slight_smile:

    So digging a little deeper into your problem :slight_smile:

    egglestonbunch.com takes me to yielder Login and madsen.egglestonbunch.com takes me to the front page of the Madsen site. If I go madsen.egglestonbunch.com/wp-admin I do get the login page but that is as far as I can go without login info.

    I checked your DNS Server NS65.DOMAINCONTROL.COM and the settings are correct.

    But what I am thinking is possibly your concept of how this works is off ..... so lets find out :slight_smile:

    On egglestonbunch.com is the Multi Site install?

    The Multi Site install is Sub-Domain and not Sub Directory?

    Please advise :slight_smile:

    Joe :slight_smile:

  • chrisegg

    Well that IP is for my multisite instal which is on the Yieldler.com domain. There are about 12 other sites setup on that multisite with domain names being mapped to the IP. I am pretty sure it is dedicated IP because it is for my backspace dedicated cloud server.

    egglestonbunch.com is not the domain the multisite is installed on, yieldler.com is.

    The multisite install is sub-domain and not directory.

    I thought this plugin was to enable you to have multiple domains on one multisite install. So the multisite is installed on yieldler.com, but with this plugin I can add egglestonbunch.com to the multisite so I can create sites using that domain as well, like madsen@egglestonbunch.com. That is my understanding of the plugin...am I mistaken?

    both the root domain and sub domain resolve to this IP.

    Yes, I do not use the root domain of egglestonbunch.com, and I pointed it to the same IP when I was troubleshooting my issue.

    Thanks
    Chris

  • aecnu

    Greetings Chris :slight_smile:

    sir thank you for the detailed reply :slight_smile: That helped a lot to figure out what is going on there :slight_smile:

    OK the way this should be working is that of course your Multi-Site is on Yielder.com

    With the Multi-Domain Plugin you would set the A record of egglestonbunch.com pointed at the IP

    Next you need to add another CNAME record *.egglestonbunch.com so it will send any domain whatever.egglestonbunch.com at the IP

    Do you have the CNAME record *.egglestonbunch.com?

    If not you may add this and everything starts working as anticipated :slight_smile:

    Concerning dedicated IP - the IP I am referring to would just have your Multi Site on it regardless of how many domains are pointing at the WP MS install - there would be no other domains resolving to the IP. Therefore the IP is still shared since other domains then your WP MS install.

    This is not required it just helps to know :slight_smile:

    I await to hear about the *.egglestonbunch.com and we shall go forward from there :slight_smile:

    Joe :slight_smile:

  • aecnu

    Greetings Chris :slight_smile:

    sir I am sorry but I made a mistake with the CNAME - the A record is correct.

    Somehow last night in my minds eye I pictured the record as a CNAME which is incorrect and that is what I get for working on too many things at one time and for this I sincerely apologize.

    As soon as I seen your message this morning I realized I had made the mistake and responded with this response.

    Forward --> so you have both *.egglestonbunch.com and *.yielder.com A records.

    You enabled "Sunrise" in your wp-config.php file and in addition added sunrise.php to your wp-content folder?

    Are you running Domain Mapping sir?

    You then went into the dashboard and created new site madsen.egglestonbunch.com?

    Joe :slight_smile:

  • chrisegg

    Alright guys I thought I had it figured out...maybe I do...

    Before I started using Multi-Domain, I was already using Domain-Mapping, but not the WPMU plugin. I was using this one, http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping. I already had the file, sunrise.php in the wp-content folder so when I added Multi-Domain I did not make any changes to that file.

    One of the troubleshooting things I did was remove the domain-mapping plugin I was using and switched to WPMU's domain-mapping plugin. Again not messing with the sunrise.php file.

    I was a little confused by the instruction for the multi-domain plugin, which instructed,

    4. Upload sunrise.php to the /wp-content folder on your site - If you are using the domain mapping plugin, rename dm_sunrise.php to sunrise.php and upload it to the /wp-content folder on your site

    I did not have dm_sunrise.php so I ignored this step. But I just looked into the Multi-domain plugin files I downloaded from WPMU and it has the wp-content folder with dm_sunrise.php, sunrise.php and mu-plugins in it. So I just added the dm_sunrise.php file to my wp-content folder and overwrote my existing sunrise.php file with the one in the plugin files.

    That allowed me to login to madsen.egglestonbunch.com. Resolving my original issue. HOWEVER, it broke the domain-mapping plugin. My domains were no longer being mapped...

    So I put my original sunrise.php file back into the wp-content folder, overwriting the one that was in the plugin folder and now EVERYTHING WORKS GREAT!

    Is that not a little strange?

    Anyway, thank you both for your help!

    - Chris