Can not see "Front Page" listed under 'all pages' using Gillie Theme

I am trying to have the front page of http://vip.MYURL.com protected via Membership2.

When I go to ‘All Pages’ the front page does not show.

1: Why is that?

2: How can I set the front page to be visible by only ‘VIP Members?’ (have a look – Support Access is granted)

Please do NOT refer me to those “Password Protected” and “WP Site Protect” plugins. They do not work well with multisite

I have NOT made any custom code edits

I am aware of the wpmudev blog entries example https://premium.wpmudev.org/blog/how-to-make-a-site-private-in-wordpress-multisite/

I would like to know specifically:

When I go to ‘All Pages’ the front page does not show.

1: Why is that?

2: How can I set the front page to be visible by only ‘VIP Members?’ (have a look – Support Access is granted)

Thanks in advance

  • Luís
    • Support

    Hi BGF ,

    Hope you're doing well today!

    The Home page in Upfront is a virtual page, so, it will not be listed in the "Pages" section. From what I tested in my install, to protect this page using Membership 2 Pro, can you please try:

    1) Go to Membership 2 -> Add-ons and enable "Protect Special Pages";

    2) In the Membership 2 -> Protection rules -> Special Pages, give the access to the "Membership" you want.

    I hope this information has been helpful. If I can help you in this or other questions, please let me know!

    Cheers, Luís

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.