Can only complete transaction when logged in

I am able to complete a purchase from the store successfully only when I am logged into the site.
We do not want customers to create accounts or login to Wordpress to make transactions.
If you are not logged in, the problem is that it keeps saying you have 0 items in your cart and you can't complete the transaction.
if you would like to test it, use OMGTESTING as the coupon code to check out (it will give you 100% discount).
I think I have turned off everything that requires customers to be logged in. Can you check? Thanks!

  • Tyler Postle
    • CGO

    Hey Emily,

    I'm not an expert on this, so I may be mistaken here, but it sounds like this could be a caching issue. Do you have any caching plugins activated? If you do, de-activate them and clear your browser cache, see if that fixes it. If not, then I'm sure a WPMU Dev expert will be by shortly!

    Cheers

  • emily_garman
    • Site Builder, Child of Zeus

    Thank you--that is definitely a consideration, and I should have mentioned that I have tried it on three different computers (in different locations with different IP addresses), in 3 different browsers and have cleared the cache on all! I was hoping it would be that simple!!

  • Jack Kitterhing
    • Code Norris

    Hi there @emily_garman,

    Hope you're well today, thanks for granting access.

    I've been taking a look at this and everything looks good settings wise, but the issue seems to be the cached.

    Your not caching for known users which is good, but your caching all pages for all visitors, so it's caching the store and checkout pages and then displaying them which is why the purchases aren't working, with that disabled it seems to work correctly, can you verify that? :slight_smile:

    Thanks!

    Kind Regards
    Jack

  • emily_garman
    • Site Builder, Child of Zeus

    OK, I have upgraded. here is my .htaccess:

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    #If you serve pages from behind a proxy you may want to change 'RewriteCond %{HTTPS} on' to something more sensible
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:stuck_out_tongue:rofile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{HTTPS} on
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{SERVER_NAME}/$1/index-https.html.gz -f
    RewriteRule ^(.*) "/wp-content/cache/supercache/%{SERVER_NAME}/$1/index-https.html.gz" [L]

    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:stuck_out_tongue:rofile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{HTTPS} !on
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{SERVER_NAME}/$1/index.html.gz -f
    RewriteRule ^(.*) "/wp-content/cache/supercache/%{SERVER_NAME}/$1/index.html.gz" [L]

    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:stuck_out_tongue:rofile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTPS} on
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{SERVER_NAME}/$1/index-https.html -f
    RewriteRule ^(.*) "/wp-content/cache/supercache/%{SERVER_NAME}/$1/index-https.html" [L]

    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:stuck_out_tongue:rofile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTPS} !on
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{SERVER_NAME}/$1/index.html -f
    RewriteRule ^(.*) "/wp-content/cache/supercache/%{SERVER_NAME}/$1/index.html" [L]
    </IfModule>

    # END WPSuperCache

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  • Jack Kitterhing
    • Code Norris

    Hi there @emily_garman,

    Hope you're well today, thanks for the additional info.

    Can you disable the cache and any files related to the cache in wp-content, by renaming the advanced-cache.php files etc.

    Then set your .htaccess to

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Removing everything else and see if that works?

    Thanks!

    Kind Regards
    Jack.

  • emily_garman
    • Site Builder, Child of Zeus

    Okay, this has completely broken my theme/website now; I get the following error when I try to go to the site or the admin area. I must now try to restore my .htaccess file, I guess, and hope that works!:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@rrus.org and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.2.22 (Unix) mod_ssl/2.2.22 OpenSSL/0.9.8e-fips-rhel5 DAV/2 mod_fcgid/2.3.6 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at http://www.rrus.org Port 80

  • emily_garman
    • Site Builder, Child of Zeus

    Thank you--still having problems.

    I disabled the caching plugin. I wonder if it is still caching somewhere, though? I pulled up a browser I don't use often and accessed the site. I tried adding products to my cart, emptying my cart, etc. It would add items to my cart that I never selected, and even when I emptied my cart, it would show 0 items in cart, but when I Clicked on the cart they would still be there.

    Do you think the issue is with the floating cart plugin? I have no choice but to use this, because without it, there is no clear/easy way for customers to FIND their cart once they have placed an item in it. (I can put a link in the sidebar or the navigation, but that is not clear or intuitive for customers).

    If you like, I can give you admin privileges on the site and you can login and see what's going on? I will go ahead and extend admin privileges for another 72 hours. Thanks for your help!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.